Announcement

Collapse
No announcement yet.

HELP -- Error MER-PAY-ATH-00016 from Authorize.net

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP -- Error MER-PAY-ATH-00016 from Authorize.net

    One of my clients is getting this error from the Authorize.net module, version 5.8003, running on PR8 Update 5 and VM 5.12.

    Record not found: MER-PAY-ATH-00016

    Can someone (MMCorp) give me some clues on what would cause this? It's only happening for one customer, but the client's getting worried, and I'd like to get them an answer ASAP. If an in-house developer will email me, I'll provide additional info, logins, etc.

    Thanks --
    Kent Multer
    Magic Metal Productions
    http://TheMagicM.com
    * Web developer/designer
    * E-commerce and Miva
    * Author, The Official Miva Web Scripting Book -- available on-line:
    http://www.amazon.com/exec/obidos/ISBN=0966103211/magicmetalproducA

  • #2
    Re: HELP -- Error MER-PAY-ATH-00016 from Authorize.net

    Kent,

    Does this happen on every order placed?
    Wayne Smith
    Miva Merchant Support Manager

    Comment


    • #3
      Re: HELP -- Error MER-PAY-ATH-00016 from Authorize.net

      This store is running a Reorder Manager module that I wrote, which lets customers select certain items to be re-purchased automatically at specific intervals, such as once a month. There's an admin page that lets the store manager create new orders, using data saved with the original purchase. This all works fine for the most part, but it's failing for this one customer.

      My module "pretends to be Merchant;" it creates a new basket, loads the items into it, sets up the necessary global variables, and then calls PaymentModule_Authorize to charge the credit card. The error message is coming from inside the Authorize.net module; without source code, it will be difficult to figure out what's really going on in there. If someone can tell me more about that error message -- what "record" is not being found -- that will be a big help.

      Thanks --
      Last edited by Kent Multer; 04-06-12, 01:53 PM.
      Kent Multer
      Magic Metal Productions
      http://TheMagicM.com
      * Web developer/designer
      * E-commerce and Miva
      * Author, The Official Miva Web Scripting Book -- available on-line:
      http://www.amazon.com/exec/obidos/ISBN=0966103211/magicmetalproducA

      Comment


      • #4
        Re: HELP -- Error MER-PAY-ATH-00016 from Authorize.net

        Kent,

        Unfotunately I don't have anyone from development today because of the holiday. I did send an email but development will more than likely respond on Monday.
        Wayne Smith
        Miva Merchant Support Manager

        Comment


        • #5
          Re: HELP -- Error MER-PAY-ATH-00016 from Authorize.net

          I'm shocked and dismayed by your reply ...

          'cuz I had no idea today was a holiday :^) .

          Thanks --
          Kent Multer
          Magic Metal Productions
          http://TheMagicM.com
          * Web developer/designer
          * E-commerce and Miva
          * Author, The Official Miva Web Scripting Book -- available on-line:
          http://www.amazon.com/exec/obidos/ISBN=0966103211/magicmetalproducA

          Comment


          • #6
            Re: HELP -- Error MER-PAY-ATH-00016 from Authorize.net

            Kent,

            From development:

            That error is caused by a payment method code that doesn't exist in sNN_AuthNetMethods. Are they using a one page checkout or do they otherwise have a hard-coded list of payment methods on their OPAY page? Have methods been deleted from that table? (The module never deletes records from that table itself).
            Wayne Smith
            Miva Merchant Support Manager

            Comment


            • #7
              Re: HELP -- Error MER-PAY-ATH-00016 from Authorize.net

              Thanks, I was able to find the problem. This store is running one of my Reorder manager modules, which allows customers to have items shipped to them automatically at regular intervals. The problem is caused by a change in the Auth.net module. It used to use "American Express" as a payment-method code, but newer versions use "AmerExp." My module was trying to charge credit cards with the new payment module, but using data from an older version. Once I knew the problem, it was easy to fix.

              Thanks for your help --
              Kent Multer
              Magic Metal Productions
              http://TheMagicM.com
              * Web developer/designer
              * E-commerce and Miva
              * Author, The Official Miva Web Scripting Book -- available on-line:
              http://www.amazon.com/exec/obidos/ISBN=0966103211/magicmetalproducA

              Comment

              Working...
              X