No announcement yet.

Script times out after years of use

  • Filter
  • Time
  • Show
Clear All
new posts

    Script times out after years of use

    I have Miva Empresa 5 installed on two different CentOS servers. These are cPanel managed servers by the way.
    I installed Empresa on both servers using Standard Mode.

    Both servers are running four scripts I developed.
    All of a sudden one of the four scripts started timing out yesterday.

    It's interesting that three of the four scripts still work fine.

    The script that is timing out is quite a bit bigger than the other three though.
    One thing I tried was deleting a bunch of the data records to reduce the size of the database.
    That did not fix the problem.

    I'm guessing that one of cPanel's nightly updates affected how cgi scripts are running.
    cPanel tech support was not able to identify any system errors indicating what is wrong.

    I'm not really sure how to continue troubleshooting this issue:

    Any comments would be greatly appreciated.

    Thank you,
    Tim Mallardi

    Tests I would do....
    - If you have the ability - check and delete any running miva processes.
    - Replace your data with just a few records
    - reboot your server
    - run rootkit check
    - check your server log - is it being used without you knowing?
    - login via terminal and run top. (there is a way to check this in cpanel) - what is your server utilization? Is it high?
    - are you out of hard drive space?
    - is there something mis-entered in the database causing the script to loop or perhaps not finding the End Of File?
    - What is the time stamp on the script? Was it recently changed?
    - Break the script in half and test both. Find which half messes up - then break that one in half, etc.

    These are some of the things I do when trying to locate a problem.
    Off hand I would say there is an entry in the database that incorrect (like a comma or something) and the script is looping. (Assuming you or someone else has not recently edited the script).

    William Gilligan - Orange Marmalade, Inc.


      Hey Bill,

      Once again, you've helped me nail a problem.

      I isolated the code and discovered that I did indeed have an infinite loop condition.
      I have no idea why the problem hasn't surface before though. That snippet of code has not changed in years.

      Now I've created another mess. I tried upgrading to the latest Empressa, and I've created a Internal server error 500.

      I'm going to start a new thread for that issue though.

      Thanks for your help!