No announcement yet.

Miva Mia 5.34 Runtime error: MvOPEN: System library "MYSQLCLIENT" is not registered

  • Filter
  • Time
  • Show
Clear All
new posts

    Hi Scott,

    Great and exciting news! Thanks for sharing! I will give this upgrade a shot and see if I have similar luck.



      Here is the rest of what I did:

      For reference only:

      The DLL to add is named “libmysql.dll”. It's in this folder and you can link directly to it:

      C:\Program Files\MySQL\MySQL Server 5.6\lib

      I don't see this documented. Add the library to Mia as a system library.
      In the METHOD add the entry -- MYSQLCLIENT.
      Then APPLY and Shutdown and restart Mia. I was able to load an MM9 store after that.

      I had tested a bunch of entries and I am not sure exactly which entry worked. It worked when I added it as a system library.

      Note: I need to use the Windows Registry to DELETE the library entries for some reason. The Mia option to do this doesn't appear to actually delete an entry so far for me.

      What help do you need today!
      Interactive Design Solutions
      MivaMerchant Business Partner | Certified MivaMerchant Web Developer
      My T-shirt Collection is mostly MivaCon T-shirts!!
      Competitive Rates, Popular Modules, and Integrations:
      Product Copy | AutoBaskets | Waitlist Integration| Wholesale Integration