Announcement

Collapse
No announcement yet.

Reasons why ReadyThemes often Set Autocomplete = Off

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reasons why ReadyThemes often Set Autocomplete = Off

    Like the title says...just curious as to the reasoning behind it...it might make sense in a shared environment...but who shops on shared computers anymore (and why are we still protecting them :) )
    Bruce Golub
    Phosphor Media - "Your Success is our Business"

    Improve Your Customer Service | Get MORE Customers | Edit CSS/Javascript/HTML Easily | Make Your Site Faster | Get Indexed by Google | Free Modules | Follow Us on Facebook
    phosphormedia.com

  • Hi Bruce,

    Since many of the newer ReadyThemes contain custom JavaScript which is activated on changes to form fields, this setting should help with functionality. Unfortunately, there is no unified style of support across browsers or platforms. I will look into if this is still a viable setting for the future of ReadyThemes.
    Matt Zimmermann
    Director of UI/UX Standards and Theme Development
    / Miva, Inc.

    Comment


    • Interesting...are you referring to the auto-complete trigger sometimes feeding the DOM onChange event based on browser? Yea, I guess that would be a pain to write based on browser version...i do believe someone wrote a jQuery script that could accommodate this (i.e., I used it once about a year ago and have no recollection where...if I remember, i'll forward it on.)
      Bruce Golub
      Phosphor Media - "Your Success is our Business"

      Improve Your Customer Service | Get MORE Customers | Edit CSS/Javascript/HTML Easily | Make Your Site Faster | Get Indexed by Google | Free Modules | Follow Us on Facebook
      phosphormedia.com

      Comment


      • I may have found another reason not to have autocomplete on - trying to use an address validation service (Addressy). The autocomplete is interfering with Addressy's ability to do its job.
        Leslie Kirk
        Miva Merchant Certified Developer
        Miva Merchant Specialist since 1997
        Previously of Webs Your Way
        (aka Leslie Nord leslienord)

        Email me: [email protected]
        www.lesliekirk.com

        Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

        Comment


        • Had an issue with autocomplete recently => Chrome from time to time is trying to ignore a global autocomplete="off" directive. Because of that customers were not able to register, as some fields in the hidden part of the registration form were autocompleted by chrome.

          Comment


          • Originally posted by AHerb View Post
            Had an issue with autocomplete recently => Chrome from time to time is trying to ignore a global autocomplete="off" directive. Because of that customers were not able to register, as some fields in the hidden part of the registration form were autocompleted by chrome.
            I used autocomplete="false" and it seems to have worked like a charm.
            Leslie Kirk
            Miva Merchant Certified Developer
            Miva Merchant Specialist since 1997
            Previously of Webs Your Way
            (aka Leslie Nord leslienord)

            Email me: [email protected]
            www.lesliekirk.com

            Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

            Comment

            Working...
            X

            This website uses cookies to identify visitors, track visitors to our website, store login session information and to remember your user preferences. By continuing to use this site you agree to our use of cookies. Learn More.

            This website uses cookies. By continuing to use this site you agree to our use of cookies. Learn More.

            Accept