Announcement

Collapse
No announcement yet.

Session IDs in ReadyTheme Links

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Session IDs in ReadyTheme Links

    I just noticed something as I build a store on Shadows. The links that I set up using any of the navigation sets in the ReadyTheme setting aren't adding the session ID in the URL that's being generated. I noticed this as I started testing logging in to an account an then navigating around the store. As soon as I select a link from any of the navigation I set up, the session ID disappears and I'm logged out of the account. It's not as if I'm adding in a manual URL into the navigation item setting. I'm selecting the page, category or product options from the drop-down menu.

    It happens with links that I set up in ReadyTheme images as well. At least some of them. As a test, I set up a link to the exact same category for both the SFNT hero image ( storefront_hero_image) as well as the small promo 1 image ( storefront_promo_small_01). The hero image adds the session ID correctly to the URL but the small promo image does not. Even though the link goes to the exact same category.

    Is it to do with the item tag in the page template itself perhaps?

    Thanks,





    Tony Pavao
    Studio6t6
    Vancouver BC Canada
    [email protected]

    #2
    Hi Tony,

    Make sure you have the following settings:
    • Domain Settings -> Cookie Settings -> Non-secure Miva Merchant Cookie Output: Set only on HTTPS connections, with secure flag
    • Domain Settings -> Site Configuration -> Include Session Parameters in Miva Merchant URLs: Never

    Matt Zimmermann
    Front-End Development Director / Miva, Inc.

    Comment


      #3
      Originally posted by studio6t6 View Post
      I just noticed something as I build a store on Shadows. The links that I set up using any of the navigation sets in the ReadyTheme setting aren't adding the session ID in the URL that's being generated. I noticed this as I started testing logging in to an account an then navigating around the store. As soon as I select a link from any of the navigation I set up, the session ID disappears and I'm logged out of the account. It's not as if I'm adding in a manual URL into the navigation item setting. I'm selecting the page, category or product options from the drop-down menu.

      It happens with links that I set up in ReadyTheme images as well. At least some of them. As a test, I set up a link to the exact same category for both the SFNT hero image ( storefront_hero_image) as well as the small promo 1 image ( storefront_promo_small_01). The hero image adds the session ID correctly to the URL but the small promo image does not. Even though the link goes to the exact same category.

      Is it to do with the item tag in the page template itself perhaps?

      Thanks,




      FYI - you don't need the Session ID if your store is properly configured to use all HTTPS (using the settings Matt listed).
      Leslie Kirk
      Miva Certified Developer
      Miva Merchant Specialist since 1997
      Previously of Webs Your Way
      (aka Leslie Nord leslienord)

      Email me: [email protected]
      www.lesliekirk.com

      Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

      Comment


        #4
        I tried Matt's method (Include Session Parameters in Miva Merchant URLs: Never), and that didn't work. This domain is hosted with a third-party host. So I went to another domain that I manage that's hosted by Miva and that setting for Include Session Parameters in Miva Merchant URLs: was set to: Always. So I went back to the original domain that was giving me issues and set it to "always" as well. Now it works!

        Interesting point you make Leslie about not needing the session ID. The session ID's don't always show up on every link, but I now always stay logged in as I should.

        Thank you both!
        Tony Pavao
        Studio6t6
        Vancouver BC Canada
        [email protected]

        Comment


          #5
          Just a follow up...

          Turns out that I was still having issues with being logged out, so I decided to go back to Matt's original instructions and this time it did what it was designed to do. I guess I missed something the first time. Now I stay logged in with NO session ID's on ANY of the links, which I guess was the point you were trying to make Leslie. Okay, I get it! Much nicer and cleaner URL's without having the session ID's in there.

          Thanks again!








          Tony Pavao
          Studio6t6
          Vancouver BC Canada
          [email protected]

          Comment

          Working...
          X