Announcement

Collapse
No announcement yet.

Category Tree links

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Category Tree links

    I've noticed that the Category Tree links are not working correctly, as in they are not linked as expected. The accordions are working, the correct categories are being pulled in but the links are just domainname.com/Merchant2/


    But I still think I have a bigger problem - the theme updates are not "sticking". I think it might be best for me to open a support ticket. I can't do anything constructive if these fields keep resetting themselves.
    Leslie Kirk
    Miva Certified Developer
    Miva Merchant Specialist since 1997
    Previously of Webs Your Way
    (aka Leslie Nord leslienord)

    Email me: [email protected]
    www.lesliekirk.com

    Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

  • Hi Leslie,

    Was support able to get the site working so your updates "stick"?
    Matt Zimmermann
    Director of UI/UX Standards and Theme Development
    / Miva, Inc.

    Comment


    • Originally posted by Matt Zimmermann View Post
      Hi Leslie,

      Was support able to get the site working so your updates "stick"?
      They are just now looking into it. I think there may be a bigger issue. When I went back to try and look at the Page templates, when I clicked the User Interface link, I got this error message

      Leslie Kirk
      Miva Certified Developer
      Miva Merchant Specialist since 1997
      Previously of Webs Your Way
      (aka Leslie Nord leslienord)

      Email me: [email protected]
      www.lesliekirk.com

      Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

      Comment


      • Now that support has got this ReadyTheme to stick (yeah it was weird) let's move back to the Cattree. Martin made an interesting comment that has me now asking, does Colossus not work with the Legacy SEO Settings for the Link Source? This site is set to it.



        Leslie Kirk
        Miva Certified Developer
        Miva Merchant Specialist since 1997
        Previously of Webs Your Way
        (aka Leslie Nord leslienord)

        Email me: [email protected]
        www.lesliekirk.com

        Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

        Comment


        • The link should be pulling the Canonical URI for the category, so Legacy Links should work as long as they are stock and not something custom like Emporium Plus or Sebenza. I would recommend converting to URI management though to ease maintenance and improve load time.
          Matt Zimmermann
          Director of UI/UX Standards and Theme Development
          / Miva, Inc.

          Comment


          • Originally posted by Matt Zimmermann View Post
            The link should be pulling the Canonical URI for the category, so Legacy Links should work as long as they are stock and not something custom like Emporium Plus or Sebenza. I would recommend converting to URI management though to ease maintenance and improve load time.
            I'll double check to make sure there isn't anything "custom" but I don't think there was. I did think it odd that I was told that I "had" to use the URI Management.
            Leslie Kirk
            Miva Certified Developer
            Miva Merchant Specialist since 1997
            Previously of Webs Your Way
            (aka Leslie Nord leslienord)

            Email me: [email protected]
            www.lesliekirk.com

            Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

            Comment


            • It looks like the site doesn't have anything outside of the Legacy configuration. The Legacy configuration works without issue in the ReadyTheme Navigation Sets.
              Leslie Kirk
              Miva Certified Developer
              Miva Merchant Specialist since 1997
              Previously of Webs Your Way
              (aka Leslie Nord leslienord)

              Email me: [email protected]
              www.lesliekirk.com

              Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

              Comment


              • Hi Leslie,

                Is the site using the Legacy Long Links or Short Links?
                Matt Zimmermann
                Director of UI/UX Standards and Theme Development
                / Miva, Inc.

                Comment


                • Short (Legacy SEO Settings)

                  Example for the Category link style

                  https://www.domain.com/page/Store_Co.../Category_Code
                  Leslie Kirk
                  Miva Certified Developer
                  Miva Merchant Specialist since 1997
                  Previously of Webs Your Way
                  (aka Leslie Nord leslienord)

                  Email me: [email protected]
                  www.lesliekirk.com

                  Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

                  Comment


                  • Hi Leslie,

                    It looks like the function to pull the canonical URL only functions when using URI Management and not Legacy SEO links. As I mentioned previously, I would recommend converting to URI Management to ease maintenance and improve load time.
                    Matt Zimmermann
                    Director of UI/UX Standards and Theme Development
                    / Miva, Inc.

                    Comment


                    • Originally posted by Matt Zimmermann View Post
                      Hi Leslie,

                      It looks like the function to pull the canonical URL only functions when using URI Management and not Legacy SEO links. As I mentioned previously, I would recommend converting to URI Management to ease maintenance and improve load time.
                      Thank you for confirming that for me. It sounds like it might be something that should be included in the installation documentation. Once support figures out why I keep having an issue with the site throwing an error

                      Miva Merchant returned an invalid response.
                      Function: PageList_Load_Query
                      Response:
                      I'll go back to tweaking.

                      Leslie Kirk
                      Miva Certified Developer
                      Miva Merchant Specialist since 1997
                      Previously of Webs Your Way
                      (aka Leslie Nord leslienord)

                      Email me: [email protected]
                      www.lesliekirk.com

                      Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

                      Comment


                      • I was getting that error as well on a dev site. Support found some 'caching' rules in my htaccess file that had to be removed. They said that they are already built into the framework and that was causing the issue.

                        Comment


                        • Originally posted by afiumano View Post
                          I was getting that error as well on a dev site. Support found some 'caching' rules in my htaccess file that had to be removed. They said that they are already built into the framework and that was causing the issue.
                          I would agree that it has to be something very specific to Colossus. I have never encountered this before. Support keeps telling me to clear my cache and data. Ummmm...nope.
                          Leslie Kirk
                          Miva Certified Developer
                          Miva Merchant Specialist since 1997
                          Previously of Webs Your Way
                          (aka Leslie Nord leslienord)

                          Email me: [email protected]
                          www.lesliekirk.com

                          Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

                          Comment


                          • Originally posted by lesliekirk View Post

                            I would agree that it has to be something very specific to Colossus. I have never encountered this before. Support keeps telling me to clear my cache and data. Ummmm...nope.
                            I went a took a peek, the site has these rules in the htaccess file

                            Code:
                            <IfModule mod_deflate.c>
                              # Compress HTML, CSS, JavaScript, Text, XML and fonts
                              AddOutputFilterByType DEFLATE application/javascript
                              AddOutputFilterByType DEFLATE application/rss+xml
                              AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
                              AddOutputFilterByType DEFLATE application/x-font
                              AddOutputFilterByType DEFLATE application/x-font-opentype
                              AddOutputFilterByType DEFLATE application/x-font-otf
                              AddOutputFilterByType DEFLATE application/x-font-truetype
                              AddOutputFilterByType DEFLATE application/x-font-ttf
                              AddOutputFilterByType DEFLATE application/x-javascript
                              AddOutputFilterByType DEFLATE application/xhtml+xml
                              AddOutputFilterByType DEFLATE application/xml
                              AddOutputFilterByType DEFLATE font/opentype
                              AddOutputFilterByType DEFLATE font/otf
                              AddOutputFilterByType DEFLATE font/ttf
                              AddOutputFilterByType DEFLATE image/svg+xml
                              AddOutputFilterByType DEFLATE image/x-icon
                              AddOutputFilterByType DEFLATE text/css
                              AddOutputFilterByType DEFLATE text/html
                              AddOutputFilterByType DEFLATE text/javascript
                              AddOutputFilterByType DEFLATE text/plain
                              AddOutputFilterByType DEFLATE text/xml
                            
                              # Remove browser bugs (only needed for really old browsers)
                              BrowserMatch ^Mozilla/4 gzip-only-text/html
                              BrowserMatch ^Mozilla/4\.0[678] no-gzip
                              BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
                              Header append Vary User-Agent
                            </IfModule>
                            
                            ## EXPIRES CACHING ##
                            <IfModule mod_expires.c>
                              ExpiresActive On
                              ExpiresByType image/jpg "access plus 1 year"
                              ExpiresByType image/jpeg "access plus 1 year"
                              ExpiresByType image/gif "access plus 1 year"
                              ExpiresByType image/png "access plus 1 year"
                              ExpiresByType text/css "access plus 1 month"
                              ExpiresByType application/pdf "access plus 1 month"
                              ExpiresByType text/x-javascript "access plus 1 week"
                              ExpiresByType application/javascript "access plus 1 week"
                              ExpiresByType application/x-shockwave-flash "access plus 1 month"
                              ExpiresByType application/x-font-woff "access plus 1 year"
                              ExpiresByType font/woff "access plus 1 year"
                              ExpiresByType font/woff2 "access plus 1 year"
                              ExpiresByType image/x-icon "access plus 1 year"
                              ExpiresDefault "access plus 2 days"
                              Header append Cache-Control "public"
                            </IfModule>
                            ## EXPIRES CACHING ##

                            Could these be what caused your issue?





                            Leslie Kirk
                            Miva Certified Developer
                            Miva Merchant Specialist since 1997
                            Previously of Webs Your Way
                            (aka Leslie Nord leslienord)

                            Email me: [email protected]
                            www.lesliekirk.com

                            Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

                            Comment


                            • Yes, below is what they removed from mine:

                              <IfModule mod_expires.c>
                              # Enable expirations
                              ExpiresActive On
                              # Default directive
                              ExpiresDefault "access plus 1 month"
                              # My favicon
                              ExpiresByType image/x-icon "access plus 1 year"
                              # Images
                              ExpiresByType image/gif "access plus 1 month"
                              ExpiresByType image/png "access plus 1 month"
                              ExpiresByType image/jpg "access plus 1 month"
                              ExpiresByType image/jpeg "access plus 1 month"
                              # CSS
                              ExpiresByType text/css "access plus 1 month"
                              # Javascript
                              ExpiresByType application/javascript "access plus 1 year"
                              </IfModule>

                              Comment

                              Working...
                              X

                              This website uses cookies to identify visitors, track visitors to our website, store login session information and to remember your user preferences. By continuing to use this site you agree to our use of cookies. Learn More.

                              This website uses cookies. By continuing to use this site you agree to our use of cookies. Learn More.

                              Accept