Announcement

Collapse
No announcement yet.

Undo Delete Product in Basket

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Undo Delete Product in Basket

    What would cause the Missing Product Attributes page to display after hitting Undo when a product is deleted from the basket? It looks the page remembers the attribute selections but for some reason some fields are blank even though they were filled in, and the only required field is filled out. I don't have a public link to post.

    #2
    Unless there is a subscription as part of the product, I'm not sure why the attribute wouldn't be present in the undo link. Are the attributes part of an attribute template? Does the restore link appear to have all the attributes as part of it?
    Matt Zimmermann
    Director of UI/UX
    / Miva, Inc.

    Comment


      #3
      Yes, the attributes are all attribute templates. I checked the link and it seems to have them all. The only thing I can think of is that the store is not using URI management yet. Would that effect anything?

      Comment


        #4
        It's possible that URI Management could make a difference, but there's also the possibility that a yes/no required attribute is triggering the missing attribute page even though it is being passed.
        Matt Zimmermann
        Director of UI/UX
        / Miva, Inc.

        Comment


          #5
          So I was NOT having the problem on my test store here: https://dts2290.mivamerchantdev.com/...-memorial-tree until I made the size attribute a template - then it caused the missing attribute page to come up. Any ideas why that would be and how to fix?

          Comment


            #6
            The undo link can be temperamental when it comes to attribute templates, I have not been able to suss out why this can happen. You might try copying the attribute template instead of using it and see if that corrects the issue.
            Matt Zimmermann
            Director of UI/UX
            / Miva, Inc.

            Comment


              #7
              I recall running into this before. The problem i believe was the checkbox options. We added query to ensure it was selected and just supressed the initial message since everything gets checked again.
              Bruce Golub
              Phosphor Media - "Your Success is our Business"

              Improve Your Customer Service | Get MORE Customers | Edit CSS/Javascript/HTML Easily | Make Your Site Faster | Get Indexed by Google | Free Modules | Follow Us on Facebook
              phosphormedia.com

              Comment


                #8
                Originally posted by Matt Zimmermann View Post
                The undo link can be temperamental when it comes to attribute templates, I have not been able to suss out why this can happen. You might try copying the attribute template instead of using it and see if that corrects the issue.
                True, but that wouldn't be a permanent fix unless I don't use attribute templates which would be annoying based on how many products they have.

                Comment


                  #9
                  I tried removing the checkbox attribute in my test store but still get the missing attribute page. Then I copied the attribute template and it worked just fine. So in this case it seems to be connected to making the radio button attribute into an attribute template.

                  Comment

                  Working...
                  X