Announcement

Collapse
No announcement yet.

Sublime Text Editor

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sublime Text Editor

    I want to get Sublime connected to my store in the worst way, but I'm not having much luck. Can anybody help?

    I have installed Sublime 3 on Windows 10 machine.

    I downloaded this package - https://github.com/rguisewite/MvSublimeTemplateEditor and that seems to have worked. At least in Sublime, under Preferences>Package Settings I show MvSublimeTemplateEditor

    And I have sublime_templateeditor module V.9 installed and active on my store.

    But I don't know what to do from here...


    Matt E.
    www.harpkit.com

  • You need to go to the package settings: Preferences -> Package Settings -> MvSublimeTextEditor -> Setings Default

    Here you can modify the JSON to include your store code, URL, username and password, local_exported_templates path.

    Once done, save it and restart sublime. You should then be able to use the keyboard shortcuts to pull in your pages:

    ctrl+m ctrl+m - Display Menu
    ctrl+m ctrl+p - List pages
    ctrl+m ctrl+a - List Template Versions






    Brennan Heyde
    VP Developer Relations
    Miva, Inc.
    bheyde@miva.com
    https://www.miva.com

    Comment


    • Thanks, Brennan. When I open that file in sublime it shows nothing. I can open in notepad and it displays text. I tried changing the settings and saving from there but then when I reboot sublime, those shortcuts don't do anything.

      Here is what is in my settings file (MvSublimeTemplateEditor.sublime-settings)

      Code:
      {
          /* 
      
              Store Password Encryption via OpenSSL.
      
              To disable (store passwords will be saved in this settings file as plain text), use:
              "disable_master_password": true
      
              If enabled (aka, if the above command is absent), use the following options:
              "openssl_command"    : The path to your openssl executable. e.g. "/usr/bin/openssl" or "C:\\bin\\openssl.exe"
              "cipher"            : Should be "-des3" or "-aes256"
      
          */
      
          "openssl_command": "openssl",
            "cipher": "-aes256",
      
            /*
      
                Store List
      
            */
      
          "sites":
          [
              {
                  "name": "harpkit",
                  "store":
                  {
                      // the store code to grab the pages from
                      "store_code": "I put my store code in here",
      
                      // the json URL to the store
                      "json_url": "http://harpkit.com/mm5/json.mvc",
      
                      // the store login username
                      "username": "I put my username in here",
      
                      // the store login password
                      "password": "I put my password in here", // If OpenSSL (Master Password) is enabled, this password will be encrypted
      
                      // the number of seconds to spend on blocking operations
                      "timeout": 15
                  },
                  "local_exported_templates": "/c/tmp/"
              }
          ]
      }
      Matt E.
      www.harpkit.com

      Comment


      • Did you ever figure this out? I'm in the same boat... think everything is configured but shortcuts don't do anything.

        Comment


        • I changed the settings below and kinda got it to work by selecting Preferences | Package Control | and entering MvSublimeTemplateEditor but the key bindings are not working.

          "disable_master_password": true,
          "openssl_command": "openssl",
          "cipher": "-aes256",
          */
          Ray Yates
          "If I have seen further, it is by standing on the shoulders of giants."
          --- Sir Isaac Newton

          Comment


          • I am able to see the files. When I edit them I hit save, but it does not seem to push the changes back to Miva. Is there something else I am missing?

            Comment


            • I figured it out. Hit CTRL+M (twice) and hit ENTER on Commit.

              Comment

              Working...
              X

              This website uses cookies to identify visitors, track visitors to our website, store login session information and to remember your user preferences. By continuing to use this site you agree to our use of cookies. Learn More.

              This website uses cookies. By continuing to use this site you agree to our use of cookies. Learn More.

              Accept