Announcement

Collapse
No announcement yet.

Production Release 8 Bugs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Re: Production Release 8 Bugs

    Jim,

    You should post your template code (in another thread). That's definitely not a "bug" in the sense of this thread and we didn't automatically make any template changes (for swatches or otherwise) to your templates, so it's something in there.
    Thanks,

    Rick Wilson
    CEO
    Miva, Inc.
    [email protected]
    https://www.miva.com

    Comment


      Re: Production Release 8 Bugs

      Originally posted by Rick Wilson View Post
      Jim,

      You should post your template code (in another thread). That's definitely not a "bug" in the sense of this thread and we didn't automatically make any template changes (for swatches or otherwise) to your templates, so it's something in there.
      I just added "nowrap" to the table with the text in it as a workaround.

      FYI: didn't have to do this before upgrading to Version 8 and activating the image machine. (no modification were made to the templates by us)
      Jim Sisk
      Uncommon Treasures

      Comment


        Basket Weight API function is broken

        Shipping modules which use the API function basket_weight to retrieve the weight of the order may not return a correct weight if the order contains inventory variant items. It appears that if you create variants you have to put the weight of the product into each variant, instead of the master product. If you don't, the basket_weight API function sees it as zero. A store contacted miva support and they blamed it on the shipping module and said I need to fix it. I'm not sure if they expected me to fix the API basket_weight function in miva's library or somehow assign weights to the product variants within the shipping module. Needless to say, I can't fix it from my end.

        I can see why each variant needs a weight. For example, buying a music album.
        LP - 1 pound
        CD - 1/2 pound
        download - 0 pounds

        Perhaps there should be a checkbox in the variant screen that if the weights are really 0, you have to check the box in order to save the entries with no weights. Failure of the store to configure their data correctly ends up involving support (who just pushed it off on the module supplier to "fix" it) and me to diagnose the real problem with the API and how that affects ALL weight based shipping modules.
        Bill Weiland - Emporium Plus http://www.emporiumplus.com/store.mvc
        Online Documentation http://www.emporiumplus.com/tk3/v3/doc.htm
        Question http://www.emporiumplus.com/mivamodu...vc?Screen=SPTS
        Facebook http://www.facebook.com/EmporiumPlus
        Twitter http://twitter.com/emporiumplus

        Comment


          Re: Production Release 8 Bugs

          not sure if anyone else has this problem but I cannot edit a product's attributes in IE9. I can click edit product and click everywhere else but when I click on Edit Here on an attribute it does nothing.
          Thanks,
          Christine

          Comment


            Re: Production Release 8 Bugs

            Originally posted by crozon View Post
            not sure if anyone else has this problem but I cannot edit a product's attributes in IE9. I can click edit product and click everywhere else but when I click on Edit Here on an attribute it does nothing.
            Try to clear your cache, Christine - that might do the trick
            Sabine Sharp
            eCommerce Strategies & Solutions
            Glendale Designs
            Support Desk
            623.322.6066

            Comment


              Re: Production Release 8 Bugs

              Seconding that, I had the exactly same issue with Chrome that was fixed by clearing the cache.

              Comment


                Re: Production Release 8 Bugs

                Additional Product Image Permissions Error

                When uploading the additional images some of them do not get world readable permissions. The affect is that the full size image cannot be shown in the popup. It is blank. There does not seem to be any rhyme or reason for the differences. It is random. Here are two files that were uploaded. Both successfully created the smaller 274x274 image. But only the bogus4u.jpg displays in the popup. Both of these images are listed as the url for the custom product images. However, if you put the bogus5f.jpg url in the browser location, you get the alternate page not found screen. No image.

                -rw-r--r-- 1 emporiumplus psacln 6742 Jul 24 08:14 bogus4u.jpg
                -rw------- 1 emporiumplus psacln 6461 Jul 24 08:13 bogus5f.jpg

                This is resulting in the inability to comply with the new Google Product feed requirements as the url is going to a bad page instead of a readable image.

                Not only does the bug need to be fixed, but the next MM update needs to retroactively fix the permissons on images in the additional product image database. Hundreds of stores have begun uploading the additional images and will be quite upset if they have to re-upload everything in order for Google to accept their feed.
                Bill Weiland - Emporium Plus http://www.emporiumplus.com/store.mvc
                Online Documentation http://www.emporiumplus.com/tk3/v3/doc.htm
                Question http://www.emporiumplus.com/mivamodu...vc?Screen=SPTS
                Facebook http://www.facebook.com/EmporiumPlus
                Twitter http://twitter.com/emporiumplus

                Comment


                  Re: Production Release 8 Bugs

                  Originally posted by wcw View Post
                  Additional Product Image Permissions Error

                  When uploading the additional images some of them do not get world readable permissions. The affect is that the full size image cannot be shown in the popup. It is blank. There does not seem to be any rhyme or reason for the differences. It is random. Here are two files that were uploaded. Both successfully created the smaller 274x274 image. But only the bogus4u.jpg displays in the popup. Both of these images are listed as the url for the custom product images. However, if you put the bogus5f.jpg url in the browser location, you get the alternate page not found screen. No image.

                  -rw-r--r-- 1 emporiumplus psacln 6742 Jul 24 08:14 bogus4u.jpg
                  -rw------- 1 emporiumplus psacln 6461 Jul 24 08:13 bogus5f.jpg

                  This is resulting in the inability to comply with the new Google Product feed requirements as the url is going to a bad page instead of a readable image.

                  Not only does the bug need to be fixed, but the next MM update needs to retroactively fix the permissons on images in the additional product image database. Hundreds of stores have begun uploading the additional images and will be quite upset if they have to re-upload everything in order for Google to accept their feed.
                  It appears that we're not explicitly setting the permissions on uploaded additional images or generated images. This means the permissions will be subject to whatever the umask is, which will make the behavior inconsistent.

                  I've filed this bug http://bugzilla.mivamerchant.com/show_bug.cgi?id=6424 and marked it for inclusion in the next patch.

                  Comment


                    Re: Production Release 8 Bugs-Picklist error

                    Originally posted by oldsportbiker View Post
                    Is anyone else using the picklist report? I'm sure it's not a coding error on my part since I temporarily reverted back to the original Miva template code and experienced the same problem. I put in some custom SQL (, using the toolbelt), as a temporary fix since my client relies upon the picklist, but I really want to yank it out.
                    I've been unable to reproduce the issue with the default Shipment Picklist template code from PR7 or PR8. What shipping module(s) are you using, and is there any pattern where the shipments showing a method of "Unknown" correlate to a particular module?

                    Comment


                      Re: Production Release 8 Bugs

                      Originally posted by skepticwebguy View Post
                      The solution was to turn off mod_deflate. According to Rick's post (http://extranet.mivamerchant.com/for...81&postcount=8) PR8's version of JSON is not compatible with mod_deflate. PR8 release 1 will fix this problem.
                      Can someone confirm that PR8 Release 1 works with mod_deflate?

                      Comment


                        Re: Production Release 8 Bugs

                        We fixed it in Update 1.
                        Thanks,

                        Rick Wilson
                        CEO
                        Miva, Inc.
                        [email protected]
                        https://www.miva.com

                        Comment


                          Re: Production Release 8 Bugs

                          Not sure if this is a one-off or not, but I'll report it anyway.

                          Under the new Template Based Order Emails, Return Received and RMA Issued both produce an email which arrives without the return information (RMA#, product info, etc).

                          I had to go under the items tab and create a new item, label it "return" and assign cmp-mv-stdreturnfields to get these templates to work.
                          Dylan Buchfink
                          The Mattress & Sleep Company
                          http://www.tmasc.ca/

                          Comment


                            Re: Production Release 8 Bugs

                            Hi koala

                            I just tried this with my test store and it was working. Whatís your set up? Iím using a cssui store with pr8 update1.

                            Do you have any other Emails set up?

                            Thanks

                            -Eric
                            Eric Foresman
                            Software Tester
                            Miva Merchant
                            http://www.mivamerchant.com/
                            [email protected]

                            Comment


                              Re: Production Release 8 Bugs

                              This was also on my test store, although mine is MMUI, fully patched (PR8 update 1).

                              I am using all of the template based emails. They're working flawlessly now, I'm about to export the whole lot of them to our live site sometime tonight.
                              Dylan Buchfink
                              The Mattress & Sleep Company
                              http://www.tmasc.ca/

                              Comment


                                Re: Production Release 8 Bugs (FedEx)

                                I have a new fresh install of PR8.
                                Enabled FedEx shipping
                                After entering the account number, and clicking update I get:
                                "FedEx server did not return a valid response. Please check server URL."

                                Suggestions?
                                Bill
                                William Gilligan - Orange Marmalade, Inc.
                                www.OrangeMarmaladeinc.com

                                Comment

                                Working...
                                X