Announcement

Collapse
No announcement yet.

Mail Settings on Domain Settings. PLEASE MOVE or FIX Autofill

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mail Settings on Domain Settings. PLEASE MOVE or FIX Autofill

    I'm frustrated keeping fixing client sites that go in to the domain settings to adjust their admin timeout (or whatever) and they mess up their mail settings ALL THE TIME because the browser autofills the user and/or password field. Please, move this to another page or add some autocomplete=off code or something. PLEASE. This is important. Sales get lost. Emails don't go out. Admins get locked out.

    Please Miva please.

    mail.JPG
    Colin Puttick
    I solemnly swear that I am up to no good...

  • Originally posted by dreamingdigital View Post
    I'm frustrated keeping fixing client sites that go in to the domain settings to adjust their admin timeout (or whatever) and they mess up their mail settings ALL THE TIME because the browser autofills the user and/or password field. Please, move this to another page or add some autocomplete=off code or something. PLEASE. This is important. Sales get lost. Emails don't go out. Admins get locked out.

    Please Miva please.

    mail.JPG
    Hi Colin,

    autocomplete=off is on every username and password field, as well as every form that contains credential info like that in admin. As of 2015 or so Google Chrome decided that autocomplete=off should just be ignored and more or less every browser followed suit.

    We do have a bug in for mm10 to redesign those fields so that they are less likely to be accidentally overwritten, but until that change is out the only thing that we can do is suggest that they stop using auto fill on the browser that they use Miva admin with.

    Hope this helps
    -Eric
    Last edited by Eric Foresman; 02-13-20, 12:43 PM.
    Eric Foresman
    Software Tester
    Miva Merchant
    http://www.mivamerchant.com/
    [email protected]

    Comment


    • MM10 to the rescue. Or a quick patch? How hard could it be? Just one attribute on 2 fields. Boom. It can't be up on the end user because they don't have the tech skillzzzz. Or the troubleshooting 'think-ahead' skillzzzzzz.... sorry. It's a super easy fix. Please. Please?
      Colin Puttick
      I solemnly swear that I am up to no good...

      Comment


      • Please?
        Bruce Golub
        Phosphor Media - "Your Success is our Business"

        Improve Your Customer Service | Get MORE Customers | Edit CSS/Javascript/HTML Easily | Make Your Site Faster | Get Indexed by Google | Free Modules | Follow Us on Facebook
        phosphormedia.com

        Comment


        • ;) See. Come on!!! I'll be your best friend.

          Sorry. It's just how do you explain to a customer that they caused missed sales, order conf, shipping emails, gift certificates... all these didn't go out because this crazy thing that's been on that page for 100000 years. Please. :)
          Colin Puttick
          I solemnly swear that I am up to no good...

          Comment


          • We just had this issue a few minutes ago with a client (third time in two weeks). They were not able to receive the email to log in and their customers were not receiving order confirmations. Luckily I was able to login and fix it for them. Although this is a minor issue, it causes chaos for users and customers. I'm hoping it will be addressed soon also.
            Thanks,
            Christine

            Comment


            • Its pretty uncommon for domain settings to get updated that often. Curious if Auto-fill is really to blame for everyone mail setting update here.

              We do have a bug to address this. We can't just add autocomplete=off as not all browsers reference that attribute. Instead we are going to make these fields disabled until you click into them, which will prevent any accidental changes via auto-fill or any other method.
              Last edited by Brennan; 02-19-20, 01:48 PM.
              Brennan Heyde
              VP Product
              Miva, Inc.
              [email protected]
              https://www.miva.com

              Comment


              • Hi Brennan,

                Yes, that should help with some of the issue we are seeing. I agree, a good portion may be user error and not specifically auto-fill but it was strange to see this issue happen so often in such a short amount of time. One customer had it happen twice (even after we explained to watch out for it) so if there is any way to remove the option to accidentally update those fields it should help. I appreciate the response.
                Thanks,
                Christine

                Comment

                Working...
                X

                This website uses cookies to identify visitors, track visitors to our website, store login session information and to remember your user preferences. By continuing to use this site you agree to our use of cookies. Learn More.

                This website uses cookies. By continuing to use this site you agree to our use of cookies. Learn More.

                Accept