Announcement

Collapse
No announcement yet.

Sendlane

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Sendlane

    When I upgraded to version 10 the admin and storefront crashed with the following error.

    Runtime error in merchant2/5.00/modules/system/sendlane-module Oct 2020.mvc @ [000000c5:00000076]: lib/EMS_BasketOption.mv: Line 109: MvQUERY: mysql_execute: Column count doesn't match value count at row 1

    I am using the latest version of the module.

    Sendlane said the error was likely the result of a conflict with some other add on. Has anyone else had this issue? Miva disabled the addin for now.

    I'm not sure if Miva support or Sendlane support would be the person to determine which module is in conflict? I don't want to go back and forth from one to the other but not sure what is covered by our basic Miva hosting support.

    I can't really disable modules one by one and activate Sendlane because activating it would again crash the admin so that would be the end of the investigation. Is there any other way to determine the culprit?

    #2
    It looks like Sendlane has a page on upgrading to Miva 10. They specify that you must completely uninstall the old before installing the new:
    https://help.sendlane.com/article/41...-with-sendlane

    It looks like there is a lot to delete prior to installing the new.
    Gordon Currie
    Phosphor Media - "Your Success is our Business"

    Improve Your Customer Service | Get MORE Customers | Edit Any Document Easily | Free Modules | Follow Us on Facebook
    phosphormedia.com

    Comment


      #3
      Yeah too late. I was using Sendlane with Miva 9 and the latest version of their module. The person I emailed said that the newest module was compatible with Miva 10 and should not cause a problem when upgrading. They suggested that the error meant there was a conflict with one of my current modules.

      Comment


        #4
        "They suggested that the error meant there was a conflict with one of my current modules."

        This response is standard operating procedure for software companies.
        Gordon Currie
        Phosphor Media - "Your Success is our Business"

        Improve Your Customer Service | Get MORE Customers | Edit Any Document Easily | Free Modules | Follow Us on Facebook
        phosphormedia.com

        Comment


          #5
          I reached out to Miva. Let's see what happens. I'm stuck otherwise because I can't try the one by one approach if activating it generates a crash and a call to Miva support each time. I flubbed this as I set up a dev site but I created it just before I added the Sendlane module so I didn't catch the problem before I upgraded or I would have stayed on 9 until it was sorted. If all else fails I can cancel Sendlane but that might be me Monday morning pandemic induced catastrophizing as I've had excellent support from Miva and Sendlane 99% of the time.

          Comment


            #6
            Originally posted by Gordon - Phosphor Media View Post
            It looks like Sendlane has a page on upgrading to Miva 10. They specify that you must completely uninstall the old before installing the new:
            https://help.sendlane.com/article/41...-with-sendlane

            It looks like there is a lot to delete prior to installing the new.
            This sounds like it needs to be flagged as part of the update to MM10 - like the Sebenza Category Template Manager module - you can't even update to MM10 until that module is completely removed.
            Leslie Kirk
            Miva Certified Developer
            Miva Merchant Specialist since 1997
            Previously of Webs Your Way
            (aka Leslie Nord leslienord)

            Email me: [email protected]
            www.lesliekirk.com

            Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

            Comment


              #7
              Originally posted by lesliekirk View Post

              This sounds like it needs to be flagged as part of the update to MM10 - like the Sebenza Category Template Manager module - you can't even update to MM10 until that module is completely removed.
              That would be good. Even though they do have a page talking about removing the original instance it didn't come up until after I had a problem and went looking for answers since the module I used is the latest version and Miva 10 compatible.

              Comment


                #8
                Just curious about those in this thread - how long have you been using SendLane? Did you use anything like it prior like MailChimp? If so, is it worth the hassle to switch? We're considering but want to get some feedback from those that already use it.

                Comment


                  #9
                  I'm new to Sendlane and we've been having a bit of a wrestle. I don't want to give the wrong impression though as they have been professional and are hard at work getting the few issues sorted.

                  The main problem we have had has been with the module in Miva that connects to Sendlane having some errors. They ironed out the worst ones but there is a persistent one that kept appearing randomly. I have disabled the module in Miva while they work it out so no synching between them but I am able to send to the customers I already imported in to the Sendlane interface and that seems to work well. I haven't been able to test the automation yet.

                  The stats work good and it is useful to be able to see the correlation between an email and specific individual responding and buying something. The design interface works good. Automation looks promising. They also expose some Miva variables that you can use to customize the emails so looking forward to trying it if we get things worked out.

                  My understanding is that Miva and Sendlane are working on getting the issues ironed out.

                  I also have one more issue with deliverability to Outlook 365. I had Microsoft look at it and they said my settings are okay and that the issue is with Sendlane. Sendlane has been troubleshooting. I am not sure but think it might related to the fact that they send mail on behalf of user, but it shows their domain. It shouldn't be a problem accoring to Sendlane as I have SPF, DKIM and DMARC all set up right but Outlook 365 still routes it to Junk in our tests. Constant Contact which we had previously had us set up some verification thing and sent the email as if from our domain and we didn't have that issue.

                  Not an area I know enough about I confess so want to be fair to the folks at Sendlane. I'm hoping that this will be ironed out this coming week and can let you know here when it is.

                  Comment


                    #10
                    Originally posted by habreu View Post
                    I'm new to Sendlane and we've been having a bit of a wrestle. I don't want to give the wrong impression though as they have been professional and are hard at work getting the few issues sorted.

                    The main problem we have had has been with the module in Miva that connects to Sendlane having some errors. They ironed out the worst ones but there is a persistent one that kept appearing randomly. I have disabled the module in Miva while they work it out so no synching between them but I am able to send to the customers I already imported in to the Sendlane interface and that seems to work well. I haven't been able to test the automation yet.

                    The stats work good and it is useful to be able to see the correlation between an email and specific individual responding and buying something. The design interface works good. Automation looks promising. They also expose some Miva variables that you can use to customize the emails so looking forward to trying it if we get things worked out.

                    My understanding is that Miva and Sendlane are working on getting the issues ironed out.

                    I also have one more issue with deliverability to Outlook 365. I had Microsoft look at it and they said my settings are okay and that the issue is with Sendlane. Sendlane has been troubleshooting. I am not sure but think it might related to the fact that they send mail on behalf of user, but it shows their domain. It shouldn't be a problem accoring to Sendlane as I have SPF, DKIM and DMARC all set up right but Outlook 365 still routes it to Junk in our tests. Constant Contact which we had previously had us set up some verification thing and sent the email as if from our domain and we didn't have that issue.

                    Not an area I know enough about I confess so want to be fair to the folks at Sendlane. I'm hoping that this will be ironed out this coming week and can let you know here when it is.
                    We just signed-up two weeks ago with Sendlane, it still not up and running. Personally, I prefer receiving emails from directly from whomever I have a relationship with for a couple of reasons and therefore assume a significant number of people might be the same. Thus, I prefer to send them out in the same manner as we have been doing so for well over a decade. Nevertheless, I thought I give this solution a chance. Sendlane sounds promising, but wont really know until its been running for a while, who knows when that will be -I hope I am able to get a credit for the downtime. It's not like they do the integration for free.
                    Thank you, Bill Davis

                    Comment


                      #11
                      I signed up yesterday to test and I noticed the message that they are developing an updated plugin for Miva 10. I'm sure that will help.

                      Comment


                        #12
                        Originally posted by schoolsin View Post
                        I signed up yesterday to test and I noticed the message that they are developing an updated plugin for Miva 10. I'm sure that will help.
                        Can you please send me a link?
                        Thank you, Bill Davis

                        Comment


                          #13
                          The plugin I used was the updated one. There is a lingering issue.

                          The automation seems like it will be useful. We still send our email campaigns manually but we are down to 4 people so I wear many hats and always putting out fires. The result is that the SEO and marketing gets less attention that it deserves. With some well thought out automation so as to not abuse people's inbox we should be able to email more consistently and generate more traffic amd sales. But I'm with you. The boss already wants to move back to Constant Contact. I'm holding it off for now but I'm hoping for a fix sooner rather than later.

                          Comment


                            #14
                            FYI Sendlane and Miva finished whatever needed to be done. My module is active now. I'll put it through it's paces next week and report any issue but assuming it is ironed out.

                            Comment

                            Working...
                            X