Announcement

Collapse
No announcement yet.

Mystery space before header

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Mystery space before header

    I cannot for the life of me figure out what is causing an approximately 20-pixel blank space before the <header>. Well, I sort of can...it looks like it's "#text 0 20 Flex item" if I mouseover the empty space while using Google Inspector. But what the heck?
    Last edited by lesliekirk; 05-25-21, 10:10 AM.
    Leslie Kirk
    Miva Certified Developer
    Miva Merchant Specialist since 1997
    Previously of Webs Your Way
    (aka Leslie Nord leslienord)

    Email me: [email protected]
    www.lesliekirk.com

    Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

    #2
    Hi Leslie,

    Looks like you might have something wonky in your HEAD tag as I see styles bleeding into the BODY tag.
    Matt Zimmermann
    Front-End Development Director / Miva, Inc.

    Comment


      #3
      Originally posted by Matt Zimmermann View Post
      Hi Leslie,

      Looks like you might have something wonky in your HEAD tag as I see styles bleeding into the BODY tag.
      I discovered two instances of the Font Awesome CSS. Deleted one and it's better now.
      Leslie Kirk
      Miva Certified Developer
      Miva Merchant Specialist since 1997
      Previously of Webs Your Way
      (aka Leslie Nord leslienord)

      Email me: [email protected]
      www.lesliekirk.com

      Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

      Comment


        #4
        I have another issue I don't understand. If I use rel="stylesheet" - the gap appears at the top and the back to top icon appears in the lower right corner as needed

        Code:
        <link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css" media="all" rel="stylesheet">
        If I remove the rel="stylesheet" - the gap disappears but the back to top icon is missing

        Code:
        <link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css" media="all">
        FYI - I have tried placing the rel="stylesheet" before the href and it makes no difference.
        Leslie Kirk
        Miva Certified Developer
        Miva Merchant Specialist since 1997
        Previously of Webs Your Way
        (aka Leslie Nord leslienord)

        Email me: [email protected]
        www.lesliekirk.com

        Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

        Comment


          #5
          Hi Leslie,

          I would look into the loading order and see if there is still something amiss with the elements in the HEAD tag as I still see them bleeding into the BODY. You might try adding Font Awesome to the CSS Resource Group as well and see if that helps.
          Matt Zimmermann
          Front-End Development Director / Miva, Inc.

          Comment


            #6
            Try using an HTML validator to see if there is a missing " or end tag somewhere.
            Bruce Golub
            Phosphor Media - "Your Success is our Business"

            Improve Your Customer Service | Get MORE Customers | Edit CSS/Javascript/HTML Easily | Make Your Site Faster | Get Indexed by Google | Free Modules | Follow Us on Facebook
            phosphormedia.com

            Comment

            Working...
            X