Announcement

Collapse
No announcement yet.

Miva Merchant 10.00.x Bug Reports

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Unfortunately, the issue is being caused by the legacy framework you're using on your site. We don't plan to push out updates for this issue since those legacy themes haven't been updates in over 4 years, which is why we recommend a custom solution going forward if you wish to keep that piece of functionality.
    Where's the Dislike button. Glad I only had 12 products to deal with and not 1200...

    Did you come up with a decent workaround? I know the newer frameworks will default to the first option if no options are selected. Or you can select an option for default. Not the solution I'm looking for really.
    Ron Frigon
    The Web Dude at J. Rousek Toy Co.

    Comment


      There is no workaround according to my contact at support unless you pay. I asked if they could ballpark a cost and this is what I got;

      I can't say for certain since I am not sure of the exact solution and what is involved, but I don't think it would be a large project to complete.

      I assume that code snippet would work on newer frameworks. I say that because when I first brought this up in the forums and listed my code several members said it was working for them when the tested in on their site for me. They did not say what framework they were on, it is just an assumption on my part based on that response.

      Comment


        Originally posted by Ron Frigon View Post
        On PROD js-price-value is overwriting the conditional. The condition does fire, but it gets over-ruled by attribute machine. This is a new issue after updating. We've used this conditional for years. The Master product price is 0.00. Price is controlled by the variant. No option is selected by default. Select a Size gets overwritten by the price of 0.00. Theme is Levels. As a temporary fix we've selected a default attribute option.
        This may explain a random issue I recently noticed and can't determine what caused the change. I am using a newer framework, Colossus. I also have a conditional around the price for when the price is 0.00. I have a custom field that shows the price range instead. It all of a sudden isn't working right. The custom field 'range' will flash for a second but once the page fully loads the variant price appears instead which is NOT supposed to happen.

        Code:
        <mvt:if expr="l.settings:product:price EQ '0.00'">
        <span class="x-product-layout-purchase__pricing-current u-color-olive">
        <span id="price-value" itemprop="price" content="&mvt:attributemachine:product:price;">
        &mvt:product:customfield_values:customfields:price _range;</span></span>
        
        <mvt:else>
        <span class="x-product-layout-purchase__pricing-current u-color-olive">
        <span id="price-value" itemprop="price" content="&mvt:product:price;">&mvt:product:formatted_price;</span>
        </span>
        </mvt:if>

        Comment


          Experiencing problem with ApplePay button payment option not being displayed in Mini-Basket each time a new product is added to the cart from the PROD page. However, if I refresh the page then the ApplePay button option is displayed.
          Thank you, Bill Davis

          Comment


            William Davis I'll have QA double check, but I don't believe it's designed to work in a Mini-Basket., It's designed to work on the actual Basket page and I believe Product Pages, but that's it.
            Thanks,

            Rick Wilson
            CEO
            Miva, Inc.
            [email protected]
            https://www.miva.com

            Comment


              I updated to the new(ish) PayPal Commerce Platform module at the same time that I updated to Miva 10.01.01. So I'm not sure if this is being caused by the PayPal module or the core software, but it's a behavior that I did not experience prior to applying these two updates.

              I use PayPal for processing both credit card and PayPal transactions.

              I recently had a customer make a purchase using a credit card. I needed to provide a partial refund after the order was placed. In the payment details section of the screen for the order, the authorization and capture entry shows a payment type of Credit Card: Visa.

              Payment.jpg

              But the refund entry shows a payment type of PayPal instead of Credit Card: Visa.

              Refund.jpg

              The same shows on the updated sales receipt email generated after the refund was applied.

              Email.jpg
              Todd Gibson
              Oliver + S | Sewing Patterns for Kids and the Whole Family

              Comment


                Originally posted by Ron Frigon View Post
                On PROD js-price-value is overwriting the conditional. The condition does fire, but it gets over-ruled by attribute machine. This is a new issue after updating. We've used this conditional for years. The Master product price is 0.00. Price is controlled by the variant. No option is selected by default. Select a Size gets overwritten by the price of 0.00. Theme is Levels. As a temporary fix we've selected a default attribute option.

                Code:
                <span id="js-price-value" class="product-price" data-base-price="&mvt:product:price;">
                <mvt:if expr="l.settings:product:price NE '0.00'">
                &mvt:product:formatted_price;
                <mvt:else>
                Select a Size for Pricing &amp; Details
                </mvt:if>
                </span>
                Wow, Ron, wow! I think you have nailed the issue I posted here https://www.miva.com/forums/forum/on...-range-snippet

                The site is Suivant and it is a custom solution that the store owner had done for her. Wow!
                Leslie Kirk
                Miva Certified Developer
                Miva Merchant Specialist since 1997
                Previously of Webs Your Way
                (aka Leslie Nord leslienord)

                Email me: [email protected]
                www.lesliekirk.com

                Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

                Comment


                  lesliekirk Yep, there’s a similar issue that started affecting my site as well, and I’m not using a ReadyTheme.

                  On PROD page only, our sale price is being overwritten by regular price. The sale price shows for a second, but then reverts back and shows full price.
                  It was working fine for us for years too and broke after update.

                  Not sure if it’s the same exact issue, but sounds very similar
                  Last edited by delcorsets; 08-22-21, 03:04 AM.
                  Psydde Delicious
                  Delicious Boutique & Corseterie
                  Philadelphia, PA
                  www.DeliciousBoutique.com
                  www.DeliciousCorsets.com

                  Comment


                    I just noticed that the new sales tax calculation seems to be calculating before discounts instead of after discounts. This is using the Shopper Selected Sales Tax module. I don't see any options on my price group setups or module configuration to control this new behavior. Am I missing something?

                    Edit: Actually, it seems like it's not recalculating tax if the customer signs into their account after starting checkout, even though the basket lines recalculate pricing. We do have a customized checkout flow where we assign the tax option in BASK and skip OSEL, but I never noticed this issue before the recent update. Is this considered a bug or will we have to manually call the tax calculation action again?
                    Last edited by joshpappas; 08-24-21, 08:38 AM.

                    Comment


                      There's another issue I noticed, this time related to the new search features (which are great). After I set everything up, I noticed that had to separately go back to my SRCH page to set "relevance" as my default sorting method. However, the Search Preview Settings page doesn't currently have "Relevance" as an option, so my search preview results don't match my search page and aren't giving the desired results. Will that be updated separately to provide this new sorting option?

                      Comment


                        I was creating a manual order in Miva and when assigning a coupon to the order I got the following error:

                        The order ended up accepting the coupon despite the error but I thought I would bring it up since I'm not sure what caused it.

                        Screen Shot 2021-09-10 at 7.44.32 AM.png

                        Attached Files
                        Psydde Delicious
                        Delicious Boutique & Corseterie
                        Philadelphia, PA
                        www.DeliciousBoutique.com
                        www.DeliciousCorsets.com

                        Comment


                          I had a similar issue when a customer accidentally created 2 accounts.

                          After moving the order from 1 account to the other preferred account, for some reason the coupon didn't transfer.

                          Yet, when I went to assign the coupon to the order I noticed it was still assigned but not showing up on the order itself.

                          When I unassigned it from the order I received that same error.

                          I was however able to reassign the coupon and it showed up on the order again.

                          Seems to be a bug for sure.

                          Comment


                            Possible bug: Product options that add a charge occassionally 'break' and no longer update price > possibly due to Related Products

                            Version Miva Merchant 10.01.01
                            MivaScript Engine v5.35
                            Database API mysql

                            For reasons I cannot determine every so often product pages that previously updated the price (when clicking on radio button options that add to the price) stop working. It seems to happen to all products in a category but I may be wrong. See this product which previously worked fine. Other products in the same parent category seem to also be broken except for 2nd linked product below which was the one I fixed.

                            https://www.allfrom1supply.com/mini-...ttom-seal.html

                            I tried the new product copy feature and when I copied 'all attributes' using that the copied product also failed but I created a 'STRIP NON-ESSENIALS' rule and unchecked each of the attributes one at a time to narrow down the culprit.

                            I eventually found that I was able to correctly copy this product by unchecking 'Related Products' and the copy of the product's options then correctly update the price.

                            https://www.allfrom1supply.com/roll-...eal-v1500.html

                            I also went back to the original product and by removing the 3 Related Products it had the original product began to update the price normally.

                            I am not sure if this is something we broke or it is a bug so figured I'd post it here in case anyone else can verify.

                            A few more points which may or may not be related.

                            - I use the product import/export every so often
                            - I have used the 'related products' import a few times but not during the time this last error became apparent to the best of my recollection
                            - I notice some product URI's disappear from time to time - including this affected product and I had to recreate it because I noticed it was using the old style links

                            Thanks.



                            Last edited by habreu; 09-17-21, 12:08 PM.

                            Comment


                              The following code was after the Related Products code block. I moved it before and works and that fixed it so I'm guessing we (as in I an me) broke it at some point.

                              Code:
                              <mvt:item name="attributemachine" param="body" / >
                              [ script ]
                              if (typeof am&mvt:product:id; !== 'undefined') {
                              var attrMachCall = am&mvt:product:id;;
                              };
                              [ /script ]
                              Last edited by habreu; 09-17-21, 12:27 PM.

                              Comment


                                So I created a new template branch by copying the primary branch to test out how this works.

                                It appears that when you are working on the new branch and make a change, the change is live on the site.

                                If you go back to the Primary branch, the change is no longer shown.

                                Here is how I tested.

                                1. Copied the "Primary Branch" and named the new branch "New Checkout Flow".

                                2. Went into the new branch and added the word "Hello!" the header of the ACLN page template and hit update.

                                3. Checked the live site and it was showing in the header of that page.

                                4. Went back into Miva and switched back to editing the primary branch

                                5. The word "Hello!" was no longer in the header section of the page template and also no longer showing on the live site.

                                Is this a bug?

                                I thought the branch templates were to make it possible to have a "Dev Environment" that doesn't effect the live site.

                                Did I make the wrong assumption?

                                Thanks

                                Comment

                                Working...
                                X