Announcement

Collapse
No announcement yet.

Miva Merchant 10.00.x Bug Reports

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    You have until the end of July to update, they should have their module updated long before then. We provided them detailed instructions on what they were doing improperly and how to fix it.
    Thanks,

    Rick Wilson
    CEO
    Miva, Inc.
    [email protected]
    https://www.miva.com

    Comment


      Here's one.

      When adding a product to an order in the admin, the products won't pull in the attributes unless you attached a customer account to the order first.

      You can't just fill in a customer's info to get the attributes to populate. you actually have to attach a customer's account.

      Our customer service team noticed this new behavior on Monday. The situation they're in is they frequently price an order for a customer over the phone by creating an order in the admin, and then collect the name/address/info if the customer chooses to go ahead and place the order. They're not always in a position to start with a customer account.
      Screenshot 2021-07-07 102851.pngimage.png

      Comment


        Originally posted by Mark Stephens View Post
        Here's one.

        When adding a product to an order in the admin, the products won't pull in the attributes unless you attached a customer account to the order first.

        You can't just fill in a customer's info to get the attributes to populate. you actually have to attach a customer's account.

        Our customer service team noticed this new behavior on Monday. The situation they're in is they frequently price an order for a customer over the phone by creating an order in the admin, and then collect the name/address/info if the customer chooses to go ahead and place the order. They're not always in a position to start with a customer account.
        Screenshot 2021-07-07 102851.pngimage.png

        Hi Mark,

        Thanks for letting us know about this, I have filed a bug for this issue.

        Many thanks
        -Eric

        Eric Foresman
        Software Tester
        Miva Merchant
        http://www.mivamerchant.com/
        [email protected]

        Comment


          Copy Product Creating a Second Copied Product?

          I'm using Miva's new Copy Product feature to copy a product, and it's resulting in the copy and also a duplicate copy product. I can't seem to find the "duplicate copy" in the catalog to remove it, and I can't seem to figure out what's causing it to happen.. I've created other copies successfully without this issue.

          Firm Molded Bra Cup - White is the copied (and duplicate) product shown below:

          Screen Shot 2021-07-14 at 11.05.11 AM.png
          Attached Files
          Psydde Delicious
          Delicious Boutique & Corseterie
          Philadelphia, PA
          www.DeliciousBoutique.com
          www.DeliciousCorsets.com

          Comment


            Originally posted by delcorsets View Post
            Copy Product Creating a Second Copied Product?

            I'm using Miva's new Copy Product feature to copy a product, and it's resulting in the copy and also a duplicate copy product. I can't seem to find the "duplicate copy" in the catalog to remove it, and I can't seem to figure out what's causing it to happen.. I've created other copies successfully without this issue.

            Firm Molded Bra Cup - White is the copied (and duplicate) product shown below:

            Screen Shot 2021-07-14 at 11.05.11 AM.png
            After a little testing I found that the duplicate appeared when I started Tracking Inventory on the copy. When I unchecked the Track Inventory box the duplicate disappeared. I was then able to re-check and start tracking inventory again and the duplicate did not reappear.
            Psydde Delicious
            Delicious Boutique & Corseterie
            Philadelphia, PA
            www.DeliciousBoutique.com
            www.DeliciousCorsets.com

            Comment


              Originally posted by delcorsets View Post
              Copy Product Creating a Second Copied Product?

              I'm using Miva's new Copy Product feature to copy a product, and it's resulting in the copy and also a duplicate copy product. I can't seem to find the "duplicate copy" in the catalog to remove it, and I can't seem to figure out what's causing it to happen.. I've created other copies successfully without this issue.

              Firm Molded Bra Cup - White is the copied (and duplicate) product shown below:

              Screen Shot 2021-07-14 at 11.05.11 AM.png
              Hi Psydde

              Just so that I am understanding this correctly, after copying the product, you see two additional versions at runtime, but only the intentional copy in admin?

              If so, then I think I have seen something like this before when there were duplicate records on the inventory tables.

              I recommend crating a service ticket, and asking support to check the database records for your copied product.

              Hope this helps.
              -Eric

              ---edit---

              guess i should have refreshed the page before posting, im glad you were able to clear the issue, but i am
              curious on how the product got into that start.
              Eric Foresman
              Software Tester
              Miva Merchant
              http://www.mivamerchant.com/
              [email protected]

              Comment


                Originally posted by Eric Foresman View Post

                Hi Psydde

                Just so that I am understanding this correctly, after copying the product, you see two additional versions at runtime, but only the intentional copy in admin?

                If so, then I think I have seen something like this before when there were duplicate records on the inventory tables.

                I recommend crating a service ticket, and asking support to check the database records for your copied product.

                Hope this helps.
                -Eric
                Eric Foresman I've been able to replicate this bug, and I've figured out how to get rid of the "phantom product".


                1) I select Copy Product from product detail screen

                2) I re-name the product and product code in the modal window to be unique

                3) After creating the copy I check the category page on the live site and see just one instance of the newly created/copied product.

                4) I check “Track Inventory” under the Inventory tab for the newly created product (the origin product did not have Track Inventory checked)

                5) I re-load the category page on the front end of the site and now the phantom product appears.

                6) I un-check the Track Inventory checkbox, reload the category page on front end of site, and the phantom product goes away.

                7) I can now check the Track Inventory box again and this time the phantom product does not reappear.

                I've tested this 3 times with the same outcome each time.

                Seems like a bug.
                Psydde Delicious
                Delicious Boutique & Corseterie
                Philadelphia, PA
                www.DeliciousBoutique.com
                www.DeliciousCorsets.com

                Comment


                  Eric, product copy is also not generating the URI for the new item. Do you know when this BUG will be fixed?

                  Comment


                    Originally posted by delcorsets View Post

                    Eric Foresman I've been able to replicate this bug, and I've figured out how to get rid of the "phantom product".


                    1) I select Copy Product from product detail screen

                    2) I re-name the product and product code in the modal window to be unique

                    3) After creating the copy I check the category page on the live site and see just one instance of the newly created/copied product.

                    4) I check “Track Inventory” under the Inventory tab for the newly created product (the origin product did not have Track Inventory checked)

                    5) I re-load the category page on the front end of the site and now the phantom product appears.

                    6) I un-check the Track Inventory checkbox, reload the category page on front end of site, and the phantom product goes away.

                    7) I can now check the Track Inventory box again and this time the phantom product does not reappear.

                    I've tested this 3 times with the same outcome each time.

                    Seems like a bug.
                    Hi Psydde

                    thanks for the detailed steps to reproduce.

                    however this did not happen when i tried it in my test store.

                    this is happening for every product in your catalog?

                    -Eric
                    Eric Foresman
                    Software Tester
                    Miva Merchant
                    http://www.mivamerchant.com/
                    [email protected]

                    Comment


                      Originally posted by Zinbar View Post
                      Eric, product copy is also not generating the URI for the new item. Do you know when this BUG will be fixed?
                      Hi Zinbar

                      we do have a bug on that issue and it is currently slated to be fixed in mm10.01.02

                      @ Psydde

                      i still have not been able to reproduce the issue you are seeing, were you able to reproduce that with every product in the catalog, or was it three times with that one product?

                      -Eric

                      Eric Foresman
                      Software Tester
                      Miva Merchant
                      http://www.mivamerchant.com/
                      [email protected]

                      Comment


                        Originally posted by Eric Foresman View Post

                        @ Psydde

                        i still have not been able to reproduce the issue you are seeing, were you able to reproduce that with every product in the catalog, or was it three times with that one product?

                        -Eric
                        Eric, it was the same product. I’m currently away, but I can test further next week
                        Psydde Delicious
                        Delicious Boutique & Corseterie
                        Philadelphia, PA
                        www.DeliciousBoutique.com
                        www.DeliciousCorsets.com

                        Comment


                          Originally posted by delcorsets View Post

                          Eric, it was the same product. I’m currently away, but I can test further next week
                          Hi Psydde

                          i was able to reproduce this issue and i have filed a bug for it. the root cause is an orphaned InventoryProductCounts record on the Original product you copied. if you turn on inventory for that product it will probably display twice at runtime too.

                          that said, if you turn on and then off inventory for that product it should clear the orphaned record and any copies you make after that will be free of the issue.

                          hope this helps and thanks for letting us know about this.

                          -Eric
                          Eric Foresman
                          Software Tester
                          Miva Merchant
                          http://www.mivamerchant.com/
                          [email protected]

                          Comment


                            FYI the new Sendlane Module is now available in the App Store: https://apps.miva.com/sendlane-for-miva.html
                            Thanks,

                            Rick Wilson
                            CEO
                            Miva, Inc.
                            [email protected]
                            https://www.miva.com

                            Comment


                              On PROD js-price-value is overwriting the conditional. The condition does fire, but it gets over-ruled by attribute machine. This is a new issue after updating. We've used this conditional for years. The Master product price is 0.00. Price is controlled by the variant. No option is selected by default. Select a Size gets overwritten by the price of 0.00. Theme is Levels. As a temporary fix we've selected a default attribute option.

                              Code:
                              <span id="js-price-value" class="product-price" data-base-price="&mvt:product:price;">
                                  <mvt:if expr="l.settings:product:price NE '0.00'">
                                      &mvt:product:formatted_price;
                                  <mvt:else>
                                      Select a Size for Pricing &amp; Details
                                  </mvt:if>
                              </span>
                              Ron Frigon
                              The Web Dude at J. Rousek Toy Co.

                              Comment


                                On PROD js-price-value is overwriting the conditional. The condition does fire, but it gets over-ruled by attribute machine. This is a new issue after updating. We've used this conditional for years. The Master product price is 0.00. Price is controlled by the variant. No option is selected by default. Select a Size gets overwritten by the price of 0.00. Theme is Levels. As a temporary fix we've selected a default attribute option.
                                Same problem here with Iron & Wool after update. Support says:

                                Unfortunately, the issue is being caused by the legacy framework you're using on your site. We don't plan to push out updates for this issue since those legacy themes haven't been updates in over 4 years, which is why we recommend a custom solution going forward if you wish to keep that piece of functionality.

                                Comment

                                Working...
                                X