Announcement

Collapse
No announcement yet.

Miva Merchant 10.00.x Bug Reports

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Inventory Kit Builder:

    • The kit product will display it's assigned Main Image on Category Pages, however once on the Product Page the only images that are displayed are the Main Images of the kit's parts. (bug or feature?)
    - If feature, is there a way to display the kit's main image in addition to the images of it's components on the Product Page?

    • After being added to the cart, the image used on the Basket Page is the product image of one of the assigned kit components, not the main image of the kit product itself.
    - Basket Page image should show the Kit Product’s Main image.

    • When an order containing a kit is imported into ShipStation, ShipStation shows the image of the kit's component instead of the kit's actual product image, but even worse, it shows the component's SKU instead of the SKU for the kit itself. This is causing a lot of confusion for order pullers. (Surely a bug, not a feature.)
    - ShipStation should display the image and SKU of the kit product, not of a component.

    I've found that this problem exists in both our stores - one running Miva 9 and one running Miva 10.
    Last edited by delcorsets; 10-16-20, 05:11 AM.
    Psydde Delicious
    Delicious Boutique & Corseterie
    Philadelphia, PA
    www.DeliciousBoutique.com
    www.DeliciousCorsets.com

    Comment


      #32
      The way kit images work on the product page is if any of the kit parts have the same image type of that master product, the kit products overwrite that of the mater. This is why you are seeing the kit images on the product page and not the master images.

      A one solution would be to give the master an image type not used by the kit parts so it never gets replaced.

      As for shipstation, the current integration never supported kits in Miva so it behaves strangely. I'm not sure there is a solution to this currently, however we are working on a new integration with them which will address this (and other issues)
      Brennan Heyde
      VP Product
      Miva, Inc.
      [email protected]
      https://www.miva.com

      Comment


        #33
        Brennan thanks for the info. I'll experiment by adding an Image Type of "Kit" and see how things behave.

        **Update: I changed the kit product's Image Type from "Main" to "Kit". It now displays as the first image on the Product Page which is nice. However, the images in the Confirmation Emails (Merchant and Customer,) are wrong, and the Basket Images are also still incorrect.

        I'm glad to hear that Miva is still working with ShipStatoin on a new integration.. I remember that project being brought up at the last IRL MivaCon. Can we look forward to seeing the new integration sometime this year, or is it further out than that?
        Last edited by delcorsets; 10-16-20, 05:14 AM.
        Psydde Delicious
        Delicious Boutique & Corseterie
        Philadelphia, PA
        www.DeliciousBoutique.com
        www.DeliciousCorsets.com

        Comment


          #34
          Q1 is my guess
          Thanks,

          Rick Wilson
          CEO
          Miva, Inc.
          [email protected]
          https://www.miva.com

          Comment


            #35
            I just found a bug on the Modules page. When you type text in the Search box, the store only searches the module name. It doesn't search for a match in the module code, vendor, or other fields.

            This is a significant inconvenience for me. I've written a lot of modules in the last 18 years, and many of my clients use more than one. All my module have codes that start with "MAGIC_." When I log into a store to do some work, I often start by doing a quick check to see which of my modules the store is using. I used to be able to do this by just typing MAGIC_ in the Search box. That doesn't work any more. I have to either scroll through the entire list of modules, or type in module names one at a time to find out if they're installed.

            Thanks --
            Kent Multer
            Magic Metal Productions
            http://TheMagicM.com
            * Web developer/designer
            * E-commerce and Miva
            * Author, The Official Miva Web Scripting Book -- available on-line:
            http://www.amazon.com/exec/obidos/IS...icmetalproducA

            Comment


              #36
              CORRECTION: the problem seems to be worse than I thought at first. I'm looking at a store that was just upgraded to v10, and it seemed that the custom tax module I wrote for them was not accepted for the upgrade. On the Modules page, I can't find it at all. Typing in the first part of the module name doesn't cause it to show up.

              The Type menu doesn't even include "Tax" as one of the options. The only types in the menu are Shipping, Payment, Fulfillment, Utility, System Ex, and Logging. What happened to all the others?

              When I looked at Store Settings, I found that my module actually is in the store, and it's selected as the current tax module. So that part, at least, is OK. But it's weird that I can't find it on the Modules page.
              Kent Multer
              Magic Metal Productions
              http://TheMagicM.com
              * Web developer/designer
              * E-commerce and Miva
              * Author, The Official Miva Web Scripting Book -- available on-line:
              http://www.amazon.com/exec/obidos/IS...icmetalproducA

              Comment


                #37
                Kent Multer are you also experiencing a runtime error when trying to add available modules?

                I've created a post here that describes when the error comes up.

                https://www.miva.com/forums/forum/on...ilable-modules

                Comment


                  #38
                  Another thing I have noticed when upgrading to v10.

                  Prior to the upgrade the deferred baskets setting seemed to be doing its job as over the course of a week there would only be a couple hundred baskets created.

                  Since the update that number jumped to over 16,000 baskets in a week, most of which were empty.

                  I was thinking it may be a bug since the review baskets tool received a huge update.

                  Comment


                    #39
                    Originally posted by SidFeyDesigns View Post
                    Kent Multer are you also experiencing a runtime error when trying to add available modules?

                    I've created a post here that describes when the error comes up.

                    https://www.miva.com/forums/forum/on...ilable-modules
                    Hi Sid, No, I haven't seen that problem. But I haven't done much work in v10 stores yet. I'm subscribed to that other thread, so I'll see any new info that comes up there; and I'll post if I see the problem in any of my clients' stores.
                    Kent Multer
                    Magic Metal Productions
                    http://TheMagicM.com
                    * Web developer/designer
                    * E-commerce and Miva
                    * Author, The Official Miva Web Scripting Book -- available on-line:
                    http://www.amazon.com/exec/obidos/IS...icmetalproducA

                    Comment


                      #40
                      Testing 10 on a dev site.

                      Minor bits:

                      report1.jpg

                      Guess it should say 'manage tags'

                      and

                      report2.jpg

                      I am using a 32" monitor set to 1920 x 1080 and by default when I look at the code sections the window extends well beyond the edge of the screen which pushes the update button offscreen as well.

                      Comment


                        #41
                        Thanks, I filed a bug to correct the Alt text.

                        For the update button being hidden, do you have any of your text areas expanded to be wider than default? That is a common case we see. We currently save the settings anytime you expand a text area so next time you visit the page it loads those same settings. We have a bug filed to remove this since we now have full screen mode. Bringing your text areas back to normal should bring the update button back in to view, without having to scroll right to see it.
                        Brennan Heyde
                        VP Product
                        Miva, Inc.
                        [email protected]
                        https://www.miva.com

                        Comment


                          #42
                          prodold.jpg
                          Version 9 PROD


                          prodnew.jpg
                          Version 10 PROD

                          Okay so I dragged all the resizers for my SFNT page in version 10 dev store and the new width is saved but when I got to the PROD page I have to do the same (and I assume every other page). I looked at version 9 PROD page and it fills the screen correctly but you don't have the left menu that is in version 10 so it fits fine. I guess it copied over the page widths from the old version 9 store. It might be good to be able to have a 'reset all page widths' if that's the cause or you may need to account for the extra width on the left in red when setting the width? Hope that made sense.
                          Last edited by habreu; 10-30-20, 01:35 PM.

                          Comment


                            #43
                            Order Processing > Order Detail Screen > Order History

                            This will open a modal window with the customer's order history, but clicking on the order link does not do anything - you are not taken to the selected order as expected.

                            Screen Shot 2020-11-28 at 7.33.17 AM.png
                            Last edited by delcorsets; 12-01-20, 10:04 AM.
                            Psydde Delicious
                            Delicious Boutique & Corseterie
                            Philadelphia, PA
                            www.DeliciousBoutique.com
                            www.DeliciousCorsets.com

                            Comment


                              #44
                              Hi Psydde


                              I have reproduced this and field a bug for it. thanks for letting us know about this issue.

                              -Eric
                              Eric Foresman
                              Software Tester
                              Miva Merchant
                              http://www.mivamerchant.com/
                              [email protected]

                              Comment


                                #45
                                Let me know if you need more info for this, but if I create a javascript resource in a branch with name 'abc', I can't create a javascript resource with that same name in Production. I believe this issue popped up when I went to merge a bunch of changesets to production that included creating the new javascript resource, which the merge wasn't able to do (and thus the end result was all messed up).

                                Comment

                                Working...
                                X