Announcement

Collapse
No announcement yet.

Miva Merchant 10.00.x Bug Reports

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eric Foresman
    replied
    Originally posted by SidFeyDesigns View Post
    The Smart Breadcrumbs don't seem to be functioning like they used to.

    Prior to the update products could be assigned to multiple categories and the breadcrumbs would match the path you took to get to the product.

    Now it only shows the path based on the product's canonical category code.

    Ex:

    Product 1 is assigned to Category 1, Category 2 and Category 3 with Category 1 being the canonical category

    Breadcrumbs Before update:

    Path 1: Category 1 > Product 1
    Breadcrumbs: Category 1 > Product 1

    Path 2: Category 2 > Product 1
    Breadcrumbs: Category 2 > Product 1

    Path 3: Category 3 > Product 1
    Breadcrumbs: Category 3 > Product 1

    Breadcrumbs After update:

    Path 1: Category 1 > Product 1
    Breadcrumbs: Category 1 > Product 1

    Path 2: Category 2 > Product 1
    Breadcrumbs: Category 1 > Product 1

    Path 3: Category 3 > Product 1
    Breadcrumbs: Category 1 > Product 1

    Is this the new intended functionality or is this a bug?

    Or shall I contact support in the event that it could be due to custom code within our templates?

    Thanks in advance.
    Hi SidFeyDesigns

    I’m not able to reproduce that issue in my test store. Did you have any luck tracking this down with support?

    Thanks

    -Eric

    Leave a comment:


  • SidFeyDesigns
    replied
    The Smart Breadcrumbs don't seem to be functioning like they used to.

    Prior to the update products could be assigned to multiple categories and the breadcrumbs would match the path you took to get to the product.

    Now it only shows the path based on the product's canonical category code.

    Ex:

    Product 1 is assigned to Category 1, Category 2 and Category 3 with Category 1 being the canonical category

    Breadcrumbs Before update:

    Path 1: Category 1 > Product 1
    Breadcrumbs: Category 1 > Product 1

    Path 2: Category 2 > Product 1
    Breadcrumbs: Category 2 > Product 1

    Path 3: Category 3 > Product 1
    Breadcrumbs: Category 3 > Product 1

    Breadcrumbs After update:

    Path 1: Category 1 > Product 1
    Breadcrumbs: Category 1 > Product 1

    Path 2: Category 2 > Product 1
    Breadcrumbs: Category 1 > Product 1

    Path 3: Category 3 > Product 1
    Breadcrumbs: Category 1 > Product 1

    Is this the new intended functionality or is this a bug?

    Or shall I contact support in the event that it could be due to custom code within our templates?

    Thanks in advance.

    Leave a comment:


  • SidFeyDesigns
    replied
    Awesome.

    Not sure if this is possible but when running updates, maybe there could be an option to backup and install

    or

    Miva could just automatically run a backup before the install so there's less of a chance of losing orders/data.

    Leave a comment:


  • Rick Wilson
    replied
    The patch for 10.03.00 is back up and 10.03.01 is now out. The previous issue has been solved and for the 3 sites that restored from backup it's now safe to upgrade. For the 7 sites waiting for us to fix them, support will be updating you and applying the fix today and you should coordinate via your ticket.

    Leave a comment:


  • SidFeyDesigns
    replied
    Rick Wilson Got it, thank you.

    Glad I reported the bug.

    Joseph already restored the site to last nights backup.

    I actually recreated the orders we lost manually (they were already downloaded into ShipWorks).

    I even managed to match the original order numbers.

    The payment data was lost in Miva, but at least the customer can still look up their order from the original order confirmation.

    Luckily this only effected 3 orders and 1 customer account.

    Thank you Miva for the great and fast customer support.

    Cheers.

    Leave a comment:


  • Rick Wilson
    replied
    As of now the plan is:

    1. Put up a fixed stream tomorrow that doesn't cause this issue (there will be no way to stream 10.03.00 until then for people who didn't already stream it.

    2. For the 3 customers who we're aware of that have the issue, we're going to build a custom import file to import that paths back into your software (which is what the updated patch would do for new customers tomorrow in essence) and that'll restore all of those image paths in your store.

    This should all be complete by EOD tomorrow (March 30th).

    If you need your image paths back faster, our only current option is to restore your site to last nights backup (which will roll you back but you'll lose any data that was added after last night's backup). Or you can import those paths back in on your own as well.

    If you want us to go the restore route (or if you want to fix the paths manually) let us know.

    Leave a comment:


  • Rick Wilson
    replied
    I believe you're correct but we're still getting to the full root cause. We'll post a fix/process shortly
    Last edited by Rick Wilson; 03-29-22, 04:37 PM.

    Leave a comment:


  • lesliekirk
    replied
    Originally posted by Rick Wilson View Post
    The issue appears to only impact people who's Category Tree Template images are not using the Image Machine, so limited in scope. We've pulled the patch until it's fixed though. We expect to be able to fix this on any sites that end up with this issue.
    Point of clarification? The site I checked, uploaded these images via the standard Category Tree Tree Image which I assume is now part of the Image Machine even though not where most people used to associate uploading images using the Image Machine (via the Images tab in the Product edit screen). That would make sense then that SidFeyDesigns lost all paths because they were hand crafted and added to the field.

    Leave a comment:


  • SidFeyDesigns
    replied
    All of our Category Tree images are in their own directory (created by me) that I upload via ftp.

    The directory is graphics/category-images/

    I did this a while back when we used to just use Miva image machine generated images from certain products.

    But if I ever changed the product image and deleted the old one we would have broken images.

    So, I put them in their own directory that can't be deleted within Miva.

    Leave a comment:


  • Rick Wilson
    replied
    The issue appears to only impact people who's Category Tree Template images are not using the Image Machine, so limited in scope. We've pulled the patch until it's fixed though. We expect to be able to fix this on any sites that end up with this issue.

    Leave a comment:


  • lesliekirk
    replied
    Originally posted by SidFeyDesigns View Post
    Huge bug with the new 10.03.00 update.

    It completely wiped every category's category tree image field.

    Looks like I'll have to fill in all those fields manually, unless there is a way to retrieve what used to be in there.
    Category Tree Tree Image field? I ran the update on a dev site and checked that field after seeing this post. The site I ran the update on still has it's Category Tree Tree Image fields filled. BUT what was the image path for your fields? Do you recall? This site has graphics/00000001/7/ (how it got to 7 I do not know). Wondering if that could be part of the issue you are seeing?

    Leave a comment:


  • Rick Wilson
    replied
    No that's fine.

    Leave a comment:


  • SidFeyDesigns
    replied
    Rick Wilson I already have a ticket open with support for the recent migration to Miva's hosting, so I let Joseph Kelemen know in that ticket.

    Would you suggest I open a separate ticket?

    Thanks.

    Leave a comment:


  • Rick Wilson
    replied
    Make sure support is aware, we're working on a fix.

    Leave a comment:


  • SidFeyDesigns
    replied
    Huge bug with the new 10.03.00 update.

    It completely wiped every category's category tree image field.

    Looks like I'll have to fill in all those fields manually, unless there is a way to retrieve what used to be in there.

    Leave a comment:

Working...
X