Announcement

Collapse
No announcement yet.

Miva Merchant 10.00.x Bug Reports

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • lesliekirk
    replied
    Originally posted by afiumano View Post
    Not sure if anyone else has encountered this - we have done 11 updates to Miva 10 and had the same issue only on two stores. We installed the main 10 update. The store still shows updates are available but instead of showing the 10.1 - 10.4 bug fix updates it is still showing the 10.0 update available and if you hit continue the window just pops up again. It appears the main update has not installed properly as admin has changed only partly to the new layout and still stays: Miva Merchant 9.14.00. I have a ticket in but was wondering if anyone else has seen this? We are trying to get this done today.
    Ditto

    Leave a comment:


  • Leanne
    replied
    Yes, I had this problem. It was a caching issue. Try clearing your cache or using another browser.

    Leave a comment:


  • afiumano
    replied
    Not sure if anyone else has encountered this - we have done 11 updates to Miva 10 and had the same issue only on two stores. We installed the main 10 update. The store still shows updates are available but instead of showing the 10.1 - 10.4 bug fix updates it is still showing the 10.0 update available and if you hit continue the window just pops up again. It appears the main update has not installed properly as admin has changed only partly to the new layout and still stays: Miva Merchant 9.14.00. I have a ticket in but was wondering if anyone else has seen this? We are trying to get this done today.

    Leave a comment:


  • habreu
    replied
    Error/Sendlane/Basket/Duplicate Entry/Caching?

    I'm not sure if this is related to the Sendlane module or a Miva 10 issue so am posting it here. I have tested this in Chrome and FireFox latest versions.

    If I log in and put an item in the cart and complete a sale, then logout and go back within a few minutes to order something else with same account I get this

    Code:
    Runtime error in merchant2/5.00/modules/system/sendlane.mvc @ [0000002b:0000021c]: lib/EMS_Resource.mv: Line 25: MvQUERY: mysql_execute: Duplicate entry '71c47f77420bb5f1f2d6e9d895ae101d' for key 's01_Baskets_1'
    I assume that something is not being flushed correctly -or maybe it gets flushed after a longer period of time- but right now I have to delete the browser cache to be able to use the site after this happens as the error prevents the page from loading completely.

    Leave a comment:


  • Eric Foresman
    replied
    Originally posted by habreu View Post
    Rounding error

    This is the second time billing has mentioned an incident like this. They did modify the order via the admin to add a coupon using the ADD/REMOVE COUPONS so I am not sure if that was the cause or it is something else.

    There seems to be a difference between how the line item discount calculations and the subtotal discounts are calculated.

    Line item shows we have 12 units that each get a 16 cent volume discount. The total volume discount is 1.92. Miva shows that as 1.94 at the end of the invoice.

    If we do the math the actual cost per unit is 5.2283 after the volume discount of 3% is applied. If you multiply that in Miva x 12 you get 62.7396 which Miva rounds to 62.74 which seems to be the line item calculation. But if you round 5.2283 first to 5.23 then multiple by 12 you get 62.76 which is the number in the subtotal area. 2 cent discrepancy.



    rounding-error.jpg


    Hi habreu

    We have a bug on that issue and the fix is already in testing.

    Hope this helps
    -Eric

    Leave a comment:


  • habreu
    replied
    Rounding error

    This is the second time billing has mentioned an incident like this. They did modify the order via the admin to add a coupon using the ADD/REMOVE COUPONS so I am not sure if that was the cause or it is something else.

    There seems to be a difference between how the line item discount calculations and the subtotal discounts are calculated.

    Line item shows we have 12 units that each get a 16 cent volume discount. The total volume discount is 1.92. Miva shows that as 1.94 at the end of the invoice.

    If we do the math the actual cost per unit is 5.2283 after the volume discount of 3% is applied. If you multiply that in Miva x 12 you get 62.7396 which Miva rounds to 62.74 which seems to be the line item calculation. But if you round 5.2283 first to 5.23 then multiple by 12 you get 62.76 which is the number in the subtotal area. 2 cent discrepancy.



    rounding-error.jpg
    Last edited by habreu; 12-15-20, 10:52 AM.

    Leave a comment:


  • Eric Foresman
    replied
    Originally posted by new_user2018 View Post
    Let me know if you need more info for this, but if I create a javascript resource in a branch with name 'abc', I can't create a javascript resource with that same name in Production. I believe this issue popped up when I went to merge a bunch of changesets to production that included creating the new javascript resource, which the merge wasn't able to do (and thus the end result was all messed up).
    Hi new_user2018

    I'm not able to reproduce this. If I create a JavaScript resource in my “testing” branch, when I switch to the Production Branch it already exists.

    If possible can you open a service ticket so that support can take a look at your store?

    Thanks
    -Eric

    Leave a comment:


  • new_user2018
    replied
    Let me know if you need more info for this, but if I create a javascript resource in a branch with name 'abc', I can't create a javascript resource with that same name in Production. I believe this issue popped up when I went to merge a bunch of changesets to production that included creating the new javascript resource, which the merge wasn't able to do (and thus the end result was all messed up).

    Leave a comment:


  • Eric Foresman
    replied
    Hi Psydde


    I have reproduced this and field a bug for it. thanks for letting us know about this issue.

    -Eric

    Leave a comment:


  • delcorsets
    replied
    Order Processing > Order Detail Screen > Order History

    This will open a modal window with the customer's order history, but clicking on the order link does not do anything - you are not taken to the selected order as expected.

    Screen Shot 2020-11-28 at 7.33.17 AM.png
    Last edited by delcorsets; 12-01-20, 10:04 AM.

    Leave a comment:


  • habreu
    replied
    prodold.jpg
    Version 9 PROD


    prodnew.jpg
    Version 10 PROD

    Okay so I dragged all the resizers for my SFNT page in version 10 dev store and the new width is saved but when I got to the PROD page I have to do the same (and I assume every other page). I looked at version 9 PROD page and it fills the screen correctly but you don't have the left menu that is in version 10 so it fits fine. I guess it copied over the page widths from the old version 9 store. It might be good to be able to have a 'reset all page widths' if that's the cause or you may need to account for the extra width on the left in red when setting the width? Hope that made sense.
    Last edited by habreu; 10-30-20, 01:35 PM.

    Leave a comment:


  • Brennan
    replied
    Thanks, I filed a bug to correct the Alt text.

    For the update button being hidden, do you have any of your text areas expanded to be wider than default? That is a common case we see. We currently save the settings anytime you expand a text area so next time you visit the page it loads those same settings. We have a bug filed to remove this since we now have full screen mode. Bringing your text areas back to normal should bring the update button back in to view, without having to scroll right to see it.

    Leave a comment:


  • habreu
    replied
    Testing 10 on a dev site.

    Minor bits:

    report1.jpg

    Guess it should say 'manage tags'

    and

    report2.jpg

    I am using a 32" monitor set to 1920 x 1080 and by default when I look at the code sections the window extends well beyond the edge of the screen which pushes the update button offscreen as well.

    Leave a comment:


  • Kent Multer
    replied
    Originally posted by SidFeyDesigns View Post
    Kent Multer are you also experiencing a runtime error when trying to add available modules?

    I've created a post here that describes when the error comes up.

    https://www.miva.com/forums/forum/on...ilable-modules
    Hi Sid, No, I haven't seen that problem. But I haven't done much work in v10 stores yet. I'm subscribed to that other thread, so I'll see any new info that comes up there; and I'll post if I see the problem in any of my clients' stores.

    Leave a comment:


  • SidFeyDesigns
    replied
    Another thing I have noticed when upgrading to v10.

    Prior to the upgrade the deferred baskets setting seemed to be doing its job as over the course of a week there would only be a couple hundred baskets created.

    Since the update that number jumped to over 16,000 baskets in a week, most of which were empty.

    I was thinking it may be a bug since the review baskets tool received a huge update.

    Leave a comment:

Working...
X