Announcement

Collapse
No announcement yet.

Miva Merchant 10.00.x Bug Reports

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eric Foresman
    replied
    Originally posted by henryfrank View Post
    When adding an Order Workflow and hitting the final "Create" button I get an error that I believe is a typo. The error is this:

    clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:1287 Uncaught TypeError: dialog.Button_Add_Right_Primarye is not a function
    at OWFWorkflow_AddEditDialog.Save (clientside.mvc?T=3cfb6765&Module_Code=orderworkfl ow&Filename=combined.js:1287)
    at OWFWorkflow_AddEditDialog.Event_OnClick_Create (clientside.mvc?T=3cfb6765&Module_Code=orderworkfl ow&Filename=combined.js:960)
    at OWFWorkflow_Step_Overview.step.onClick_Create (clientside.mvc?T=3cfb6765&Module_Code=orderworkfl ow&Filename=combined.js:1005)
    at MMButton.<anonymous> (clientside.mvc?T=3cfb6765&Module_Code=orderworkfl ow&Filename=combined.js:2183)
    at MMButton.button_click_evt (clientside.mvc?T=3cfb6765&Filename=admin/core.js:5269)
    at MMButton.OnClick (clientside.mvc?T=3cfb6765&Filename=admin/core.js:5415)
    at MMButton.OnMouseUp (clientside.mvc?T=3cfb6765&Filename=admin/core.js:5523)
    at HTMLDocument.MMButton.event_mouseup (clientside.mvc?T=3cfb6765&Filename=admin/core.js:4947)
    OWFWorkflow_AddEditDialog.Save @ clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:1287
    OWFWorkflow_AddEditDialog.Event_OnClick_Create @ clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:960
    step.onClick_Create @ clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:1005
    (anonymous) @ clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:2183
    button_click_evt @ clientside.mvc?T=3cfb6765&Filename=admin/core.js:5269
    MMButton.OnClick @ clientside.mvc?T=3cfb6765&Filename=admin/core.js:5415
    MMButton.OnMouseUp @ clientside.mvc?T=3cfb6765&Filename=admin/core.js:5523
    MMButton.event_mouseup @ clientside.mvc?T=3cfb6765&Filename=admin/core.js:4947

    If I go into the Sources tab in dev tools I get this function with the error that 'dialog.Button_Add_Right_Primarye()' is not a function:

    Code:
     button_save = dialog.Button_Add_Right_Primarye( 'Save', '', function() { self.Save_LowLevel( data ); } );
    I took the 'e' off of "Primarye" making it 'dialog.Button_Add_Right_Primary' and was able to get the workflow created, though that seems like an obvious type that will prevent a lot of workflows getting created.
    Hi henryfrank

    Sorry it took me a while to reproduce this. But I have and I have now filed it as a bug. The issue is that you did not specify any conditions in the workflow. Which makes this easy to work around. Just set a condition that will always be true.

    Example:
    Order:id is greater than 1


    That will always be true cause orders start at 1000 and it will allow you to save your workflow for now.

    Thanks for letting us know about this.
    -Eric

    Leave a comment:


  • heatherwebdev
    replied
    It does only seem to happen on occasion. The email addresses have no unusual characters in them.

    Leave a comment:


  • Eric Foresman
    replied
    Originally posted by heatherwebdev View Post
    Twice, in the miva admin panel, when sending out an order email (order confirmation:merchant) I've gotten this error - 5.1.3 Bad recipient address syntax.

    I've also had a customer send in that they got an error on the site when checking out that said One or more notification emails could not be sent at this time. 5.1.3 Bad recipient address syntax.

    We've never gotten these errors before updating
    Hi heatherwebdev,

    I haven’t had any errors with those emails in testing. Do you have any additional info or data that I can try?

    Thanks
    -Eric

    Leave a comment:


  • heatherwebdev
    replied
    Twice, in the miva admin panel, when sending out an order email (order confirmation:merchant) I've gotten this error - 5.1.3 Bad recipient address syntax.

    I've also had a customer send in that they got an error on the site when checking out that said One or more notification emails could not be sent at this time. 5.1.3 Bad recipient address syntax.

    We've never gotten these errors before updating

    Leave a comment:


  • wesbosse
    replied
    In order workflow creation, the function call on "Save" button click event has a typo.

    "Primarye" -> "Primary" got it to fire correctly on my side.

    loving the new version so far!

    Leave a comment:


  • henryfrank
    replied
    When adding an Order Workflow and hitting the final "Create" button I get an error that I believe is a typo. The error is this:

    clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:1287 Uncaught TypeError: dialog.Button_Add_Right_Primarye is not a function
    at OWFWorkflow_AddEditDialog.Save (clientside.mvc?T=3cfb6765&Module_Code=orderworkfl ow&Filename=combined.js:1287)
    at OWFWorkflow_AddEditDialog.Event_OnClick_Create (clientside.mvc?T=3cfb6765&Module_Code=orderworkfl ow&Filename=combined.js:960)
    at OWFWorkflow_Step_Overview.step.onClick_Create (clientside.mvc?T=3cfb6765&Module_Code=orderworkfl ow&Filename=combined.js:1005)
    at MMButton.<anonymous> (clientside.mvc?T=3cfb6765&Module_Code=orderworkfl ow&Filename=combined.js:2183)
    at MMButton.button_click_evt (clientside.mvc?T=3cfb6765&Filename=admin/core.js:5269)
    at MMButton.OnClick (clientside.mvc?T=3cfb6765&Filename=admin/core.js:5415)
    at MMButton.OnMouseUp (clientside.mvc?T=3cfb6765&Filename=admin/core.js:5523)
    at HTMLDocument.MMButton.event_mouseup (clientside.mvc?T=3cfb6765&Filename=admin/core.js:4947)
    OWFWorkflow_AddEditDialog.Save @ clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:1287
    OWFWorkflow_AddEditDialog.Event_OnClick_Create @ clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:960
    step.onClick_Create @ clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:1005
    (anonymous) @ clientside.mvc?T=3cfb6765&Module_Code=orderworkflo w&Filename=combined.js:2183
    button_click_evt @ clientside.mvc?T=3cfb6765&Filename=admin/core.js:5269
    MMButton.OnClick @ clientside.mvc?T=3cfb6765&Filename=admin/core.js:5415
    MMButton.OnMouseUp @ clientside.mvc?T=3cfb6765&Filename=admin/core.js:5523
    MMButton.event_mouseup @ clientside.mvc?T=3cfb6765&Filename=admin/core.js:4947

    If I go into the Sources tab in dev tools I get this function with the error that 'dialog.Button_Add_Right_Primarye()' is not a function:

    Code:
     button_save = dialog.Button_Add_Right_Primarye( 'Save', '', function() { self.Save_LowLevel( data ); } );
    I took the 'e' off of "Primarye" making it 'dialog.Button_Add_Right_Primary' and was able to get the workflow created, though that seems like an obvious type that will prevent a lot of workflows getting created.

    Leave a comment:


  • Kent Multer
    replied
    OK, I can get to the product page with that. But the old button would show me the product page with one click. The new one triggers Firefox to give a warning about theadmin page opening a pop-up. So it takes me a couple more clicks to actually get the product page to appear. Not a huge problem, but can this be fixed?

    Leave a comment:


  • Eric Foresman
    replied
    Originally posted by Kent Multer View Post
    Well, I haven't bought a laptop in several years, so I don't what the common screen size is now. But there's a lot of white space on those pages; I bet you could trim it down to 1280 pixels wide without much trouble.

    Another thing I just noticed: on the admin page for editing a product, the "View on Live Store" button is gone -- at least it's not where it was before. Did that go away? I find it very useful; I use it quite often.

    Thanks --
    the view store button is now always present at the top of the screen, it is also conditional. If you happen to be viewing a product or category when you click it the page will open to that product or category, otherwise the button will open to the storefront page.

    view_store_button.png

    Leave a comment:


  • Kent Multer
    replied
    Well, I haven't bought a laptop in several years, so I don't what the common screen size is now. But there's a lot of white space on those pages; I bet you could trim it down to 1280 pixels wide without much trouble.

    Another thing I just noticed: on the admin page for editing a product, the "View on Live Store" button is gone -- at least it's not where it was before. Did that go away? I find it very useful; I use it quite often.

    Thanks --

    Leave a comment:


  • Eric Foresman
    replied
    Originally posted by Kent Multer View Post
    How do you add a new module to a domain? Previous versions had that plus-sign button on the Modules admin page, but it's gone in version 10.

    Also, in the new admin pages, I think the minimum screen size is too large. I usually keep my browser windows about 1200 pixels wide. That always worked fine in previous version of admin. But now, most of the pages seem to extend a couple of inches past the right margin; I have to scroll to see the rest of the page. I gather that the in-house developers all have huge screens. But not all of us have that luxury, especially when traveling and using a laptop.

    Thanks --
    Hi Kent

    The screen you are looking for has been moved to Menu > Domain settings> Modules (tab). There you will find the old modules screen where you can upload new modules and mark modules as active or not.

    And you are correct in mm10 the minimum screen size was updated to 1366px wide.
    -Eric

    Leave a comment:


  • Kent Multer
    replied
    How do you add a new module to a domain? Previous versions had that plus-sign button on the Modules admin page, but it's gone in version 10.

    Also, in the new admin pages, I think the minimum screen size is too large. I usually keep my browser windows about 1200 pixels wide. That always worked fine in previous version of admin. But now, most of the pages seem to extend a couple of inches past the right margin; I have to scroll to see the rest of the page. I gather that the in-house developers all have huge screens. But not all of us have that luxury, especially when traveling and using a laptop.

    Thanks --

    Leave a comment:


  • Eric Foresman
    replied
    Originally posted by heatherwebdev View Post
    I have an attribute template that is a checkbox with an inventory variant.

    When I add the template to a product, and then go to Inventory Kit Builder, I click on the Checked option, add the part, and save. But when I look at the list, it shows the part that I added under the Not Checked option. If I generate variants, I can see that the part that I added is added on the unchecked variants, and since there's a price attached to the part, when I check the live site, its adding the extra price when the option is not checked.

    This hasnt affected my current products, but if I try to add a new product with the checkbox, or edit a current product it will happen so for now I need to leave that attribute off new products.
    Hi heatherwebdev

    Sorry for the long delay in response, it took me a while to reproduce this. But I have and it has been filed.

    Thanks for letting us know about this issue.

    -Eric

    Leave a comment:


  • Eric Foresman
    replied
    Originally posted by kayakbabe View Post
    I have one customer in the store. I have added products and price groups.
    I added a business account
    I went into the business account.
    I decided to click on the tabs.
    customer, notes, orders.

    of course there are NO orders in the store yet.

    try 1.

    I did not assign a customers to the business account.
    when I click on orders. I get a mysql error.

    "mysql_stmt_prepare: Unknown column 'ba.id' in 'where clause'"

    try 2.
    Then I added the customer to the business account,
    creating an order from the admin side for the customer,
    tried to see the business account orders and I still get the same error.

    Mac Catalina 10.15.6 with Safari version Version 14.0 (15610.1.28.1.9, 15610)
    Version Miva Merchant 10.00.02
    MivaScript Engine v5.34
    miva10-bizaccount-orders-mysqlerror.png
    Hi kayakbabe

    I have filed a bug for this issue, thanks for letting us know about it.

    -Eric

    Leave a comment:


  • kayakbabe
    replied
    I have one customer in the store. I have added products and price groups.
    I added a business account
    I went into the business account.
    I decided to click on the tabs.
    customer, notes, orders.

    of course there are NO orders in the store yet.

    try 1.

    I did not assign a customers to the business account.
    when I click on orders. I get a mysql error.

    "mysql_stmt_prepare: Unknown column 'ba.id' in 'where clause'"

    try 2.
    Then I added the customer to the business account,
    creating an order from the admin side for the customer,
    tried to see the business account orders and I still get the same error.

    Mac Catalina 10.15.6 with Safari version Version 14.0 (15610.1.28.1.9, 15610)
    Version Miva Merchant 10.00.02
    MivaScript Engine v5.34
    miva10-bizaccount-orders-mysqlerror.png
    Last edited by kayakbabe; 10-02-20, 03:56 PM.

    Leave a comment:


  • heatherwebdev
    replied
    I have an attribute template that is a checkbox with an inventory variant.

    When I add the template to a product, and then go to Inventory Kit Builder, I click on the Checked option, add the part, and save. But when I look at the list, it shows the part that I added under the Not Checked option. If I generate variants, I can see that the part that I added is added on the unchecked variants, and since there's a price attached to the part, when I check the live site, its adding the extra price when the option is not checked.

    This hasnt affected my current products, but if I try to add a new product with the checkbox, or edit a current product it will happen so for now I need to leave that attribute off new products.

    Leave a comment:

Working...
X