Announcement

Collapse
No announcement yet.

Miva Merchant 9.13.x Bug Reports

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by aubreyd View Post
    MivaPrint Q does not automatically start in the background when the computer is turned on every morning. We're having to manually start the app every morning in order to print labels.

    Hi aubreyd,

    what OS are you using? i know in windows 10 its fairly easy to add almost any app to the list of startup apps that get started on boot, but i have also run the idea of adding that option to the installer by the devs to see if that is doable.

    let me know which OS you are on and i will look up and post the instructions on how to set that up.

    -Eric

    Eric Foresman
    Software Tester
    Miva Merchant
    http://www.mivamerchant.com/
    [email protected]

    Comment


    • On a Mac when you manually start the app, it'll show in the Dock (for a while), right click or control-click it and choose Options -> Open at Login.
      Thanks,

      Rick Wilson
      CEO
      Miva, Inc.
      [email protected]
      https://www.miva.com

      Comment


      • The token &mvt:navigationitem:link; isn't working as expected in within the ReadyTheme link token and the Legacy SEO Settings. It was working fine until this latest update.

        Legacy SEO Settings

        (All of these are checked)

        Enable Short Links
        Always include Store Code in URL
        Include Product Page Identifier in Breadcrumb Links

        URL Delimiter: /

        Prefix: Page

        Suffix: None

        Product Page Identifier: PROD

        Category Page Identifier: CTGY
        There are two results using this token

        CTGY links produce a Fatal Error: Unable to open store 'CTGY'

        Page links go NTFD.html (the message "We're sorry but it appears that the "NTFD.HTML" page is not available at this time.")
        Leslie Kirk
        Miva Certified Developer
        Miva Merchant Specialist since 1997
        Previously of Webs Your Way
        (aka Leslie Nord leslienord)

        Email me: [email protected]
        www.lesliekirk.com

        Follow me: Twitter | Facebook | FourSquare | Pinterest | Flickr

        Comment


        • Price groups can't have negative %. Legacy price groups do allow -%. There are use cases where -% to increase a price is useful. Especially in stores that do B2B and B2C. Please put that back into the Miva 9 price groups!

          Comment


          • Originally posted by lesliekirk View Post
            The token &mvt:navigationitem:link; isn't working as expected in within the ReadyTheme link token and the Legacy SEO Settings. It was working fine until this latest update.

            Legacy SEO Settings

            (All of these are checked)

            Enable Short Links
            Always include Store Code in URL
            Include Product Page Identifier in Breadcrumb Links

            URL Delimiter: /

            Prefix: Page

            Suffix: None

            Product Page Identifier: PROD

            Category Page Identifier: CTGY
            There are two results using this token

            CTGY links produce a Fatal Error: Unable to open store 'CTGY'

            Page links go NTFD.html (the message "We're sorry but it appears that the "NTFD.HTML" page is not available at this time.")
            A bug has been filed. A workaround would be to uncheck "Always include Store Code in URL" and then run the "Update Navigation Set Item URLs" scheduled task. (This will only work if your domain has 1 store.)
            David Carver
            Miva, Inc. | Software Developer

            Comment


            • Anyone have any insight on why the close up image on the image machine won't work or should I try creating a ticket?

              It won't work after trying to use the deferred versions of the script items.

              My original post is on page 1 of this thread.

              Thanks.

              Comment


              • Originally posted by SidFeyDesigns View Post
                Anyone have any insight on why the close up image on the image machine won't work or should I try creating a ticket?

                It won't work after trying to use the deferred versions of the script items.

                My original post is on page 1 of this thread.

                Thanks.
                You didn't note also making this change? Mine are working...

                <mvt:item name="product_display_imagemachine" param="body_deferred:product:id"/>

                https://docs.miva.com/how-to-guides/deferred-javascript
                Mark Hood
                Vermont Gear

                Comment


                • I did make that change.

                  Thought I noted that in my original post.

                  I have reverted back to the non deferred version for now until I can get this sorted out.

                  Comment


                  • Below is the js code the error is referencing in the console for the scripts file

                    Uncaught ReferenceError: gallery is not defined
                    at HTMLSpanElement.<anonymous> (prodscripts.js:284)


                    Code:
                            // ---- Open Product Image Gallery ---- //
                    
                            productGallery: function (trigger) {
                    
                                trigger.on('click', function (e) {
                    
                                    var startAt = Number($(this).attr('data-index'));
                    
                    
                    
                                    e.preventDefault();
                    
                                    if (gallery.length > 0) {X
                    
                                        $.magnificPopup.open({
                    
                                            callbacks: {
                    
                                                open: function () {
                    
                                                    $.magnificPopup.instance.goTo(startAt);
                    
                                                }
                    
                                            },
                    
                                            gallery: {
                    
                                                enabled: true
                    
                                            },
                    
                                            items: gallery,
                    
                                            type: 'image'
                    
                                        });
                    
                                    }
                    
                                    else {
                    
                                        $.magnificPopup.open({
                    
                                            items: {
                    
                                                src: $('#js-main-image').attr('data-image')
                    
                                            },
                    
                                            type: 'image'
                    
                                        });
                    
                                    };
                    
                                });
                    
                            }
                    
                    
                    
                        },

                    Comment


                    • Originally posted by Beefy Nugget View Post
                      Was there any change to the <mvt:item name="urls" in 9.13? We updated to 9.13 and our url broke when any facets were applied. The url would have "Screen=%26MVTE" and thus cause the product not found page to be displayed.
                      The solution I found to fix this was to remove the line
                      Code:
                      <mvt:item name="urls" param="hidden_params:&mvte:global:Screen;:auto" />
                      from the facet layouts.
                      Is this a problem anyone else ran into?
                      Yes!!!

                      Change instance of

                      <mvt:item name="urls" param="hidden_params:&mvte:global:Screen;:auto" />

                      and replace with

                      <mvt:item name="urls" param="hidden_params:_self:auto" />
                      Colin Puttick
                      I solemnly swear that I am up to no good...

                      Comment


                      • Originally posted by dcarver View Post

                        Yes there were changes to how / when the URLs are generated. What was your code before the change? In addition, as Bruce stated, I wouldn't expect your change to work, but I'll have to try that tomorrow when I get in.

                        **Update: I just verified that putting store morph inside of a param attribute will not work. You should open a support ticket if you continue to have this problem.
                        dcarver

                        You said "Yes there were changes to how / when the URLs are generated." but I can not find that anywhere in the release notes.
                        https://www.miva.com/forums/forum/ge...-now-available
                        We developers need a way to know when Miva does this kind of thing. Please advise.
                        Colin Puttick
                        I solemnly swear that I am up to no good...

                        Comment


                        • Originally posted by dreamingdigital View Post

                          dcarver

                          You said "Yes there were changes to how / when the URLs are generated." but I can not find that anywhere in the release notes.
                          https://www.miva.com/forums/forum/ge...-now-available
                          We developers need a way to know when Miva does this kind of thing. Please advise.
                          It is the "The CSSUI URLs component has been modified to improve performance on sites with a large number of pages." comment in the release notes. The changes made were performance improvements, but the module should act 100% identical to how it acted before. No functionality changes were made.
                          David Carver
                          Miva, Inc. | Software Developer

                          Comment


                          • "...but the module should act 100% identical to how it acted before. No functionality changes were made."

                            It doesn't on that one count. Everyone needs to update that bit of code once updating to 9.13

                            Change all instances of

                            <mvt:item name="urls" param="hidden_params:&mvte:global:Screen;:auto" />

                            with

                            <mvt:item name="urls" param="hidden_params:_self:auto" />


                            Hint Miva's template search and replace module is your friend here people of the community. :)
                            https://apps.miva.com/template-search-and-replace.html
                            Colin Puttick
                            I solemnly swear that I am up to no good...

                            Comment


                            • Originally posted by dreamingdigital View Post
                              "...but the module should act 100% identical to how it acted before. No functionality changes were made."

                              It doesn't on that one count. Everyone needs to update that bit of code once updating to 9.13

                              Change all instances of

                              <mvt:item name="urls" param="hidden_params:&mvte:global:Screen;:auto" />

                              with

                              <mvt:item name="urls" param="hidden_params:_self:auto" />
                              As far as I can tell the code snippet
                              Code:
                              <mvt:item name="urls" param="hidden_params:&mvte:global:Screen;:auto" />
                              never existed in our software. That code would have never work as I mentioned in a previous reply. We do not evaluate storemorph code within storemorph code.

                              With that being said, did you have this problem as well? Did you have to go and change that line of code to the correct version you posted or were you re-iterating Beefy Nugget? If you had to change it to, are you using any kind of ReadyTheme or other framework provided by Miva?
                              David Carver
                              Miva, Inc. | Software Developer

                              Comment


                              • I'm not sure if this unique to 9.13, but I received errors when trying to batch update pricing on multiple products on the Catalog screen.

                                Psydde Delicious
                                Delicious Boutique & Corseterie
                                Philadelphia, PA
                                www.DeliciousBoutique.com
                                www.DeliciousCorsets.com

                                Comment

                                Working...
                                X

                                This website uses cookies to identify visitors, track visitors to our website, store login session information and to remember your user preferences. By continuing to use this site you agree to our use of cookies. Learn More.

                                This website uses cookies. By continuing to use this site you agree to our use of cookies. Learn More.

                                Accept